Notched circles and depth cuts are stepped (resolved)

I’m having several problems. First is that circles are not being true and the next depth of cut is way off. This is a longer question because I include several examples of what is going on.

As you can see the first pass on the circle stutters on the upper left hand corner. The on the second pass is goes right of the first pass then things get real bad. I know the second pass is worse because it is cutting more material.

I’m using a 1/16" fishtail bit, 25 ipm and .025 depth/pass in Cast Acrylic.

I thought something might be wrong with the controller so I reset it (both ardunio and GRBL boards) and tried another cut in MDF.

Which turned out perfect.
Settings 1/16" Fishtail bit, 30 ipm and .02 Depth/pass

At this point I was getting excited that the problem was solved so I cut another Project.

Then here in the letter Y the second pass wide. This letter was in the middle of the cut so letters were cut out after it and they turned out fine. Settings 1/16" fishtail, 30 ipm and .02 Depth/pass

So now my thoughts are, is this a fluke? So I try another project.

This one I watched all the way through and everything runs fine until it cleans up the circle in the middle then the offset starts happening.
settings 1/16" fishtail, 30ipm and .02 depth/pass.

Here are the links to the files. Any help that is giving is appreciated.

Xcontroller or Gshield?

Definitely could be mechanical. Double check belt tension, pulleys, and v-wheel tension.
One other thing to check, this may sound odd, is power. I had this happen once, very similar results of missing steps and it was due to using another tool at the same time that was on the same breaker. The X-Controller is very sensitive to “dirty” power so try to not have anything running on the same breaker as the X-Carve - not your dust collector, shop-vac, etc… If you have a spare UPS you can have the X-Carve plugged into, I would do that as well since they help to “clean” up the power.

Thanks everyone for their input. I noticed that several of the v-wheels were loose so I tightened those up. Cleaned a few things and decided to give it a test to see what happened.

Running it without the router going, i noticed the X carriage was not moving but the motor was running. Looks like I had a loose pulley. tightened up the set screws and the circle problem has disappeared. Tested with a marker and paper.

Did you secure with blue Loctite?