Offline Easel?

Looking for something I can use offline to control my XCarve. I’m out in the garage now, but I can’t seem to get internet well out here. It kinda seems to be right in the middle of a carve that I loose my internet and it quits.

Easel needs the internet to open a file and to save the file but it uses Easel Local to control the machine during the cut.

If you are stopping cutting while in the middle I would check for hibernation mode or sleep mode that disconnects the USB. turn off all sleep modes and try agian.

Once the carve is started it doesn’t require the internet, are you sure you are not getting electrical interference on the USB port?

Thank y’all so much. I’ll check on the sleep settings and I have a feeling it is that that’s the problem.

Download a stable version of the Universal Gcode sender. It runs the gcode you create in Easel without internet.

https://winder.github.io/ugs_website/

1 Like

Thanks Martin.

you can also check out carbide create if you need to design and create gcode without internet. but you would then need a sender like UGS or Bcnc to control your machine with.

But then everything can be done offline.

I have had it happen several times now where it has started, gone about 5 minutes, and just stop, it really stops. It doesn’t even go back to home.

When the USB-connection drop out, the machine reset to an arbitraty machine coordinate point (It reset to zero, where ever it is at that time)
Hence there is no “home” any longer.

Work zero (home position) is stored as an offset relative to machine zero (homing switches)
If you have homing switches, one can re-home and use previous work zero.

The USB-signal chain is a weak link:

  • Have you tried an externally powered USB-hub?

Ok, so I’m kinda getting sick of this right now. I’ve gotten my 1000 working great except for the fact that it cannot seem to handle any carve that takes more than about a half hour. It’s gotten so crazy that I’m trying to break larger carves into multiple parts which adds a ton of work into the process and I still don’t have luck! The carve I’ve been working on I HAVE 6 FAILS ALREADY! I’ve gotten my internet working nicely and I’ve tried to make it so that I don’t loose usb connection, but I really can’t continue wasting wood.

You have something going on other than Easel. We need to trouble shoot that.

If you have Gcode already, can you try it with a Gcode sender and see if it does the same thing? I noticed a glitch using a laptop with Gcode sender. I think it was because the computer went to send me a message about updates. Now I put it into airplane mode. With Microsoft…there’s always some thing going on it seems, especially when you want it to be left alone.