Offset problem during cut

I’m having this issue where the spindle gets offset during a a job. It seems like it’s happening when the spindle lifts up to move onto the second cut. I’ve attached an image that shows the problem in detail. It’s a pair of sunglasses so they should obviously be symmetrical, but the image demonstrates how it gets offset.

Could this be occurring if the potentiometers aren’t perfectly calibrated?

I’ve calibrated the machine, tightened everything, but can’t seem to figure out why it’s happening. I’ve also tried with other designs and softwares so I know it’s the machine. Any help would be greatly appreciated!

What image are you referring to?

My design is fine. I’ve checked to make sure it’s symmetrical and I’ve also created other designs and the same thing happens.

I’ve tested in a solid block of pine so I know the stock isn’t moving.

I created the design in Rhino then create the toolpaths in fusion360. I can attach my .nc file when I get back to my computer that I normally use. Thank you for helping!

You are losing steps. It still needs a little tweaking.

Keep tweaking the potentiometers?

do you have a long rule marked with millimeters? Lowes sells a metal yard stick in inches and millimeters for 2 bucks and change. You can clamp it down and check your accuracy.

if you cut a perfect circle, does it come out somewhat oval or oblong?

I’m at a loss. It seems to cut a perfect circle. But if I cut another circle that is slightly offset (2 mm) inside or out, so that I’m cutting 2 circles leaving a ring with a 2 mm thickness, the issue occurs where the circles are not perfectly lined up.

run a little test:

take a piece of wood and cut say a 2 inch circle outside and a 1.5 circle inside. Then, rotate the stock 90 degrees and cut the same thing again next to it.

don’t cut all the way through, just an 1/8-1/4 inch

like this

I’ll try this out, thanks!

However I’ve actually tried something similar to this. I ran the cut that is pictured in this original post, taking note of the exact home position. Once the job was finished it returned back to the exact home position. I ran the job again from the same home position and the cut was identical.

This leads me to believe the spindle isn’t getting moved out of place during the cut.

I have been running over a year and I went through a similar problem. Circles were off, but always the same.

I swore up and down I had everything right. It turned out my belts needed tweaking.

Interesting. What kind of tweaking did you have to do?

They weren’t tight enough. I did the “fish scale” setup and found one was much tighter than the other although the sounded the same when plucked. A $5 scale did the trick along with bumping up the pots a bit.

Ill try this. I’ve got my belts pretty tight but I haven’t done any tension testing to make sure they’re equal. Are there any good videos demonstrating how to perform that test with the scale?

yes, search RobertA_Rieke in the forum. He has done some nice vids to help people get dialed in.

Oh I know him… great videos. Thanks

So today I picked up a scale, heat shrink, zip ties… secured the belts, re-tightened them, measured them and they’re all 3.5 lbs at 1 inch, and I re-calibrated the steppers. I ran a a couple tests and the problem has improved a little bit but still there.

Here’s one of the files I’ve been using where the issue occurs if anyone cares enough to try it out in Easel. It’s with a 2 flute 1/8" endmill bit. (16.6 KB)

Have you been able to solve your problem? I’m having the same issue now, and I’m looking for solutions. Belts? How about z-axis stiffness? Or could it be something in GRBL settings?

Looks to me like a normal deflection issue due to lack of stiffness, tweak the machine as above and where precision is required slow the feed rates right down to make the machine’s workload easier to lower deflection of the bit.