Oh, no! The big red button!

Newby doing first carve since X-Controller upgrade (very limited use before the upgrade, too).
Had to hit the panic button because I had a clamp in the way and the milling head (thankfully surrounded by the Suckit arms) ran into it and it started chattering and slipping.

I had earlier stopped a carve that was going well, but due to my not placing it on the work plane correctly, it wasn’t going to fit. I was piddling around and clicked the Homing button and that’s when it hit the clamp. Chalk it up to user error.

However, now when I turn on the X-Controller, the fan comes on, but no power LED on the front, and it won’t reconnect with my laptop PC.

Did you reset the E-Stop? Turn it.

I tried turning it earlier, but I was too gentle. This time I twisted it harder and it popped all the way up. Green light is back! Thanks a lot!

I am learning a lot, and this forum is very good!


Be sure to set your safe z to clear clamps. I just hit mine last week.

I am not sure what you are referring to by safe z.

Under advanced options, Safety Height.

So if the clamps are say 6mm thick and I set safe height at 8mm this should stop me from cutting into my clamps ?

say your clamps are 6mm higher on Z than the work piece, then yes 8mm should clear. (note I said should). :sunglasses: