Old ShapeOko 2 user

Thank you Steven and Brian for your suggestions.

I tried connecting with Easel, but setting up the machine doesn’t work. It says “plug the USB and start your machine”, so I do, but it doesn’t do anything. Actually, the gShield LEDs start flashing and I can hear the NEMA motors do a silent “thud”, at a pace of about once every 3 seconds.

I unplugged everything, then re-plugged and tried with Universal g-code sender. It worked! I see I have grbl 0.9a installed, though. I thought I updated it to another version back in 2014 ??? So I’m wondering… EDIT I successfully updated to 0.9g, UGS shows this version now. I noticed that there are also versions 0.9i and 0.9j but I’m not sure if I should go there…

For use with Easel, is there a minimum grbl version to have? Any suggestions on this?

I have been using the stable version 1.0.9 without problems.


Thank you Martin, my UGS installation is fine. I was talking about the grbl version.

Well, Easel now recognizes my ShapeOko 2, so I drew a line in Easel and without placing any material or spindle, I sent the code to the machine, and it worked!

Next step: securing a bit of plywood on the machine, maybe go buy a Dewalt 660 (seems to be a popular one) and get things rolling for a real test.

Updates coming soon.

Oops…sorry. My grbl board is whatever came in the Xcontroller last year. out of sight and out of mind…

Well… bought a DeWalt 660, very nice tool. Awesome, powerful.
But it doesn’t fit on the standard ShapeOko 2 Z-Axis :disappointed:
Oh well, back to the weak Jobmate rotary tool…

Maybe it fits on the S2 -> XCarve upgrade kit? If anyone can point me to where I can get/buy this kit, I’d really appreciate it…

Ok so I found the original spindle that came with the machine, I think it’s an “Altocraft” .
Set up the following test in Easel :

But when I run it, just the letter M is over 7 inches wide… even though I set the test for a 4" x 2" section…
So I stopped the carving as soon as I saw that.
Also, the MDF is level, and so is the machine (I’m fairly sure)… but the spindle doesn’t go through all the way…

Again, any help would be appreciated.


Yes I saw this one, but isn’t it to upgrade a X-Carve machine? I have a ShapeOko 2…

You need to buy the wide makerslide and the new carriage.

contact customer service for the complete list of upgrades as that page isn’t working when you click on it. There were two stages. Shapeoko2 to Xcarve and Xcarve V1 to X carve with current specs.

Unfortunately, this carriage says that it cannot hold NEMA17 motors, only NEMA23.
I have NEMA17 motors, but I guess I could buy a 23 for the X-axis. Will the gShield controler I have be enough to feed this motor?

I read a post talking about all the items to buy for the initial XCarve upgrade… that with the wide MakerSlide and the NEMA23 motor, I’m already up to 228$…

I really can’t answer those questions as I just added what the lists called for and opted for the x controller. I blew out my shapeoko2 electronics with a short so I figured the extra investment in the controller was probably a better investment for me. I really prefer plug and play, which it was after a simple assembly of the components. I also went with the aftermarket z axis and I’m about to put on the risers and stiffeners I bought during the winter. I have a lot invested, but for me my hobby is my only vice. The Shapeoko2 was in mothballs for a few years before the upgrades and now it’s getting some use again.

Thanks, Martin.

I’ll reach out to customer support and see what they suggest for upgrading my machine.

Does anyone know why my Easel project came out way too huge for what was selected? I mean the project is for a 4"x2" board that says “Marc”, but just the letter M came out being 7" wide… Maybe there’s a setting I missed somewhere?

As for not being leveled, I’ll re-check everything this weekend.

Nema17´s are lacking torque for confident cutting in “hard” materials as hardwood / aluminium.
Yes, you may get it to work but you’ll be prone to loose steps frequently => failed carves.

Nema23´s are much stronger, but don’t have more power than the stepper driver can supply, and the gshield is lacking in this department. Its particularly apparent on the Y-axis as one driver is running two steppers => each Y-stepper have 50% power vs X and Z.

For as little as $100 you can build a considerable more powerful controller, search “DIY controller”
Bill of materials, bare minimum:

  • 1x Arduino UNO
  • 4x TB6600 stepper drivers
  • 24V PSU (might be ablel to salvage old PSU from the gshield)
    => Optionally - If you shop for new PSU go with 36V

This combination will be able to provide all the current each individual stepper desire (up to 4A per phase)
Or get a X-controller, which more or less equal the listed equipment above in a ready to use box.

Have you measured the actual travel for each axis vs commanded distance?
Does 10" jog command along the X/Y axis = 10" travel?
Same applies for Z, but test smaller travel first.

1 Like

I just tested in the final setup steps of the test Easel job. In this window (check material thickness, secure the material, zero the machine, etc) there are buttons to jog the machine. I selected 1", then hit X towards the right… and the spindle moved… 6,25 inches!!!

So I have a bad setting somewhere, but I ran through the machine setup in Easel … Is there anywhere else I need to check? Maybe the grbl settings or something?

You can change your GRBL settings by doing the following, including a recalibration of the step per mm value. (Step being one step from the stepper motor):

  • Open Easel -> Machine Inspector
  • Locate the Console window, in it press $$ followed by hitting Enter. A list of GRBL commands will list in the window below.
  • Take note of the $100 value, which is your current step/mm value. Your test show this value is incorrect and need to be recalculated
  • The math is easy: take current value, multiply that with the commanded distance and divide that by the actual travel and you have your recalculated value
  • To change the GRBL parameter, simply write **$100=X" where X = your recalculated value, hit Enter.
  • Write $$ again and hit Enter to see if the new GRBL list display your change. A restart of your controller may be required.
  • Re-test and apply the same for Y-axis ($101) and Z-axis ($102)

I’ll look into these, thank you Haldor!
What about the current Arduino Uno board I have? Will it still work? What about the gShield?

The Arduino UNO you have is the brain, and reusable.
The gshield is the combined interface between UNO and machine + integrated stepper drivers.
The TB6600 mentioned are individual stepper drivers. As a bare minimum no interface board is required, but may offer convenience.