Inventables Community Forum

Pausing X-Contoller

When I have pressed pause on the X-controller in the past, the machine has done exactly that. Paused and the bit retracts in the Z- axis away from the work.
Im not aware of changing anything in the settings, but now the machine just pauses, with NO retraction in the Z-axis.
Any ideas chaps?

As far back as I recall the pause has always done what your explaining it does for you now, stays at the location.

It would only lift if stop was used.
OR it the timing of the pause happened to be during a lift command…

EDIT: after reading Neils reply :point_down: I might need to see why mine isn’t “parking” like yours was i guess :man_facepalming:

1 Like

@DudeWithABeard Have you updated firmware? This is a compile-time option to enable parking.
Can you send $I through the console in the machine inspector and report the response?

3 Likes

Ill have a go at that as soon as machine has stopped. Its half way through something. Thanks for the response guys, i appreciate it.

1 Like

Are you running dust collection? How worn are your brushes in your router? Both of these have given folks a lot of trouble, the dust collection when it gets dry.

Steve

Everything is brand new here Steve. Yes, using inventables dust collection system.

1 Like

Sorry for the delay Neil, and thanks for the intitial reply. I keyed in what you said and got this…

$I
[VER:1.1g.20170629-Inventables:]
[OPT:VMP+,15,128]
ok

When we get into the drier times of the year we start seeing a lot of this same issue/question on the forum, how well do you have your dust collection grounded?

Could that stop the Z-axis from retracting when pressing the pause button? It seemed like a GRBL issue to me? The dust extraction is gounded, using the grounding connector that was supplied with the kit. Its to a radiator in my workshop.

Past experience if it stops on its own its brushes or dry air in my case and what we see on the forum. If you are pushing the pause button might be something else.

The problem I have, is that in the past, I’ve pressed the pause button on the X-Controller. The jobs paused, the Z-Axis has moved up and away from the work. As in the original post, the machine is now not moving in the Z-Axis. Just pausing on the spot. This is leaving marks in the carving I’m doing as its stopping in one location rather that retracting first.

Thanks for getting that info.
Based on your build info, you should see a retract on pause.
Can you resume after the pause when it doesn’t retract?

Yes I can, but because its staionary i’m getting marks where the bit starts rotating on the spot…Im you get my meaning?

Can you share your $$ settings?

1 Like

I’m half way through a 5 hr carve, will that affect anything I’m doing? :confused:

It shouldn’t allow you to send any commands, but don’t jack up your carve. Just report back later. Just fishing, to be honest. I’m not sure yet why it wouldn’t park.

1 Like

Excellent. Ill do that, should be about an hour or so if the Gcode sender is telling the truth today.
Cheers. Thanks for the help.

Yes I’ll wait…

$$
G1Y71.683Z7.222 (line=140115)
error:8 (Not idle)
ok
client> ~

Job stopped :joy:
Nice burn mark I’ll have to sand out :joy: :joy:

Here you go Neil

$$
$0=10 (Step pulse time, microseconds)
$1=255 (Step idle delay, milliseconds)
$2=0 (Step pulse invert, mask)
$3=3 (Step direction invert, mask)
$4=0 (Invert step enable pin, boolean)
$5=0 (Invert limit pins, boolean)
$6=0 (Invert probe pin, boolean)
$10=115 (Status report options, mask)
$11=0.020 (Junction deviation, millimeters)
$12=0.002 (Arc tolerance, millimeters)
$13=0 (Report in inches, boolean)
$20=0 (Soft limits enable, boolean)
$21=0 (Hard limits enable, boolean)
$22=1 (Homing cycle enable, boolean)
$23=3 (Homing direction invert, mask)
$24=25.000 (Homing locate feed rate, mm/min)
$25=750.000 (Homing search seek rate, mm/min)
$26=250 (Homing switch debounce delay, milliseconds)
$27=1.000 (Homing switch pull-off distance, millimeters)
$30=1000 (Maximum spindle speed, RPM)
$31=0 (Minimum spindle speed, RPM)
$32=1 (Laser-mode enable, boolean)
$100=39.900 (X-axis travel resolution, step/mm)
$101=40.000 (Y-axis travel resolution, step/mm)
$102=188.976 (Z-axis travel resolution, step/mm)
$110=8000.000 (X-axis maximum rate, mm/min)
$111=8000.000 (Y-axis maximum rate, mm/min)
$112=500.000 (Z-axis maximum rate, mm/min)
$120=500.000 (X-axis acceleration, mm/sec^2)
$121=500.000 (Y-axis acceleration, mm/sec^2)
$122=50.000 (Z-axis acceleration, mm/sec^2)
$130=500.000 (X-axis maximum travel, millimeters)
$131=500.000 (Y-axis maximum travel, millimeters)
$132=100.000 (Z-axis maximum travel, millimeters)
ok

Aha! The fishing caught something!

Any reason you have laser mode enabled?
Set $32=0 and you’ll get your parking back.

2 Likes