Permanent y,x setup?

When proceeding to carve its asks to set the y, x. Can i make this a repeatable point so i can use mounted blocks? When it asks if i want to use the previous x,y and you click yes,the carriage really really wants to head south to cuba, every time, without exception. It will not go to a previously used point. No, i am not turning off the machine when this happens, just trying to do a second cut after changing bits.

Conversly, can i set the x, y homing without the z homing switch? If, and only if they decide they feel like working?

Make sure you dont have any objects outside of you’re work area.
“wants to head south to cuba, every time, without exception.”
Go To the Edit tab in Easel and go to Select All. If your square is exceeding past your page size then you have something else on the screen.
Or you can hit Ctrl+A at the same time on your keyboard and that’s a shortcut for select all.

1 Like

No. Everything is inside the bounding box in easel.

So, can i set a permanent x,y so i can use corner blocks?
Can i set the x,y limit switches without first setting the never worked x axis home switch?
After going through initialization and using the probe, when asked if the previous x,y is what i want to use, it heads to cuba. This is after successfully completing my first cut, changing bits, probe blah, blah, blah, it will not use the just finished coordinates.

Can you share the file?
Where are you setting your home position? and where are you placing the object to carve?

As far as using the same X and Y when Easel promps you to set new home or use last position just select use last position.
To share a file:
Select Unlisted and Highlight Link
Paste link into your replyl.

1 Like

This is when it heads south

I deleted the project file share, it shows my complete name which is never a good to do on the internet.

Russell is right with the use last postion but that would be starting from scratch again. When your carve is done and over on the lower right if you push use last x and y i will rehome the machine. I used it a couple of times and everytime it would rehome. I quit using it because of that it was much faster to reset and use last position. Not sure if that is what you are referring to.

1 Like

This is what it will not do. When i do, it heads south.

Are you saying it does not home or try to it just takes off?

Yes, it comes at me full speed and to the right.

you can save Jig positions onto the CNC itself by setting a G28 and/or G30 positions. It’s a bit tricky to do within Easelm and required you to type manual commands to move it into position each time. . . In UGS you can program Macro buttons to do it and in Openbuilds Control there are pre-set buttons for this function. (one of the many reasons I prefer OpenBuilds Control as my sender)

Hmm, the toolpaths don’t show that, so unless the jog commands are also inverted, then it shouldn’t do a you’ve explained. . . with the shooting fwd/right…

Me and the big red switch are good friends now.

1 Like

Do you have homing switches?

We havent got to the point where someone has noticed in OP that i was wondering if i can set my homing switches individually, without the x, which is screwed.

Jog does exactly what its supposed to do every time.

1 Like

Here’s a quick run down of the G28 / G30 jig saved location functions

BUT it sounds as if you’re manually moving the gantry quite a bit during the bit swap and that might be the root cause of the driving off forward and right possibly. . .

So you’d need to either perform this to lock the steppers (then you can skip the official method below)

OR this official Inventables method to re-home and use last X,Y if you haven’t set steppers to stay locked during that bit swap.

I think what Neil was getting at is if you want to set a g28 or g30 you will need to home the machine first.

1 Like

not without editing the config file and re-flashing grbl with that file. . . so basically no

Fix your X switch issue (or whatever issue you have with the switches), then the machine will work as intended.

It’s not really clear in your post if you have switches or not.

1 Like

I re-read through a couple times. . . Based on the initial comment I think its the Z that’s not working,

which makes sense, because if this is an X-carve with the new Z axis then the tab on the Z-switch just needs bent down a little, . . Or a tiny block of wood or something taped to the top of the Z bracket to make it push the Z switch a tiny bit further. . .

This is a known issue on each and every build and I still haven’t seen a PSA or any change to the assembly guide :shrug:

1 Like

Interesting. I guess I didn’t think of this, but I suppose you could modify your post-processor to home and then move to a pre-set position before executing the specified gcode.

That being said, I have found that for lots of projects, using the center of my workpiece as the 0,0 is quite a lot less work than using the lower-left.