Phil's help documents and Tutorials

Just v carve now? how long would this fairly simple stl take to set up in both as a reference?

@PhilJohnson Is there a way to have just your posts so up in this topic? I know I read somewhere you wrote the min you can carve and still get some paint in but can’t find it.

@PhilJohnson I have the TB6600 drivers set up and working but when I try to home the X axis travels a short distance then stops. it acts like the limit switch was triggered. (Going to check the wiring)
The strange thing is I can run the system using UGS and easel ok but when I try to set up the machine so I can enable the z probe for Easel it will not work at all. nothing will move on the move axis screen and the zprobe does not show contact. I can get the probe to work in UGS however.
UGS is giving me crap. I cannot use it without it throwing an error after a run change the bit then try to load a new file to re zero the Z axis. :confused:
I wish there were a way to make this stuff work without spending hours and hours trying to figure out what is wrong.

Links not working. Im not sure if it was that post or just a random comment you made somewhere with a suggested minimum depth to paint.

I have this set up already.
I have checked the wiring and even rewired it.
UGH this sucks I cannot get UGS to work without resetting it every time!
I keep getting an error after loading a .nc file from Vcarve then I try to zero it again with my files from the tool that Charlie made and it gives this For input string “-”
:frowning:

What do you like about it or what does it give you over the base setup?

I run UGS and it has no macro tab.
Are you on a Mac?

I downloaded the recent stable version from the website.
I am not on the nightly build or other versions.
I am not at home atm. when I get home I will post what I have.

1 Like

That menu is mac only.
I do not have a mac
Also there is no menu like that in the application.

On the windows version, along the top, there are tabs for machine control and file mode, there should also be a tab that says Macros. I am not near mine, and it’s windows, but I know there’s a tab across the top for macros, I use macros like Phil’s all the time… I’ll try to get a pic later tonight.

1 Like

Whats the version your running?
https://winder.github.io/ugs_website/download/
The one at the top is what I am using. 1.0.9 and there is no macros no file menu.
Would be nice to have things without all the confusion…

Here’s a pic of what I see, this isn’t my system, but a Bing search of UGS screen shots returned this, and it’s what I’m used to seeing …

Can you tell me what version you are running?

Give me about an hour, and I can run home and check the machine. I want to say it’s 0. something and not 1.something… I downloaded it about a year ago and haven’t upgraded since.

I’m in the “if it ain’t broke, don’t fix it…” school of thought. Of course I still miss Windows XP too. :frowning:

1 Like

I will try later tonight.
I know there are some issues with windows 8 and java and that could be the issue.
If so I will get windows 10 upgrade.
Thanks.

There’s no Windows / Mac version, it’s all the same. If you’re using the Classic version see the screenshot @DarrylKegg shared, on the nightly Platform build the screenshot @PhilJohnson is where it is (though the look and feel is slightly different depending on the OS).

Any clue as to why my system does not fully home.
it will fall short of the homing switch and does not alarm that homing failed.
Mainly on the X axis and all the switches are fully functional.

I just downloaded your nightly build Phil.
It has the macro tab but only 3 available. How did you get more than 3?

Just found a thread talking about the issue with homing the x axis.
Tomorrow I am going to rewire using shielded wires.
Its possible that the drivers are throwing out some stray signals.
I will also create a new proto board for the arduino for the wires to have some good solid connections.
This should fix the issue.

Forgot one main thing, make sure your maker slide is cut square, they had to send me a new one cause it was cut badly. even the new one isn’t great, I am taking it to a machine shop to have it cut perfectly.

1 Like