Picsender gcode

I am running Grbl 1.0c

Sorry to hear you are having a problem running the code. I personally use PicSender exclusively and never have any problems of any kind at all wit it. Please answer the following and perhaps we can figure out what the problem is.

When you click send to zero to the touch plate are you touching the touch plate with your bare hand?

When you click on send does PicSender display the code in the console window on the left side as it is being processed.

Does the bit move at all?

Does the bit start moving to the left and stop after about an inch before it reaches the touch plate?

Are you getting any error messages from PicSender?

What is the voltage reading between the touch plate and the bit prior to hitting the send button in Pic Sender?

Can you upload the actual file you are loading in Pic Sender (Not a copy of the txt but the actual file)

Please also paste the contents of your GRBL settings here. In the Do Command box type $$ and click Do Command. The contents of your GRBL settings will show up in the console window. Copy those and paste them here.

Are you running a trial version of PicSender or paid version?

Have you tried to run the zeroing g-code with Universal G-code Sender? (Do not use the nightly build for trouble shooting, use version 1.8 or 1.9)

Finally, if you can capture a screen shot of PicSender just prior to hitting Send and another just after hitting Send.

I’m confident that we can get this worked out and once we do I am sure that you will be very happy with the results you will be able to achieve in setting an accurate 0,0,0.

Charley Thomas
Triquetra CNC


Okay, I was using the trial version of Picsender. I now have the full version loaded. I will try again and post my results. Stay tuned.

1 Like

Thank you Michael. Demo version limitations explain your problem.


Great news, I was able to zero my xcarve using Picsender and Triquetra!!! I greatly appreciate the help from everyone who responded. I have another question, Will I have to zero each time that I change bits? Again thank you all for your help.


1 Like

Okay I went back in to re-zero and now the code that I saved will not work. What am I doing wrong??? It tells me Line#15: Alarm Lock.

Did you home your machine again?

1 Like


Try the $X Kill Alarm Lock button and try zeroing again.

1 Like

I did but the machine tripped my limit switch which is in the opposite direction.

Okay< I shut down and restarted. I re homed then I loaded the Fine tune code then hit send. the machine triped the limit switch and I get this from picsender: Line number 6. Alarm probe failed. Not sure what is going on.

I don’t know either. Calling @CharleyThomas & @JohnChamplain

I m also getting GRBL response: error: Alarm Lock. This is really getting annoying.

I cant believe that it would be in the wiring just for the fact that I have done 3-6 projects before I loaded Picsender and did not have a problem. I loaded Picsender so I could zero the bit using the Triqueira. Even after I get the program to zero when I shut down or change the bit I am unable to get the program to zero again with the code that was created by the Triqueria.

Futher more I am unable to get Picsender to work at all now.

This is an alarm message direct from Grbl, not from PicSender. It is usually associated with a shorted probe when beginning a probe move. Make sure you are clear of any limit switches and your probe is not shorted to ground when you run Charley’s code. Sometimes, touching the probe with your hand can cause the alarm with some machines with a grounding problem. Your body can act as a ground shorting the probe.

1 Like

Please describe this better. Do you get any error messages? Does PS connect OK? Can you post a screen shot if PS connects or not?

1 Like

John I get a limit switch tripped when the nothing is touching the limit switch. This is the a screen shot at start up

Here is a screen shot of the fine tun gcode that I have been trying to run.