PicSender Move Speed

I’ve recently installed a Triquetra Touch Plate. I’ve been using UGS to send the GCODE for the touch sequence. It works great except for having to manually zero the axis in UGS after the touch sequence.

I tried Picsender to give it a test run. It works very well, except for the carriage speed when I manually tell it to do a move (to set bit in position for touch sequence). The carriage moves VERY SLOWLY in very small steps. Do I have to initially send some GCODE commands to tell the carriage to move faster?

I’ve had my X-Carve for about a year, but I just started exploring the mysteries of GCODE.

Note: the Triquetra Touch Plate is a fantastic investment. Everything works as promised. My initial pre-purchase questions were promptly answered, shipping was fast and reasonably priced, and the packaging was great (everything was separately shrink wrapped). Excellent service.

What is the feed rate setting (box above the jogging controls)?

1 Like

$0=10 (step pulse, usec)
$1=0 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000011)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=1 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=39.631 (x, step/mm)
$101=39.798 (y, step/mm)
$102=188.976 (z, step/mm)
$110=8000.000 (x max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=500.000 (x accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=790.000 (x max travel, mm)
$131=790.000 (y max travel, mm)
$132=100.000 (z max travel, mm)


I would recommend that you change this to 255 ($1=255). That will keep the stepper motors on which will help your machine maintain its position when it is idle.

Below the gold “Mode” display and above the jogging controls, change the feed rate to something like 100 inches/m.

That should increase your jogging speed. Play around with that setting to get the speed that you want.

1 Like

tnx, I’ll give it a try.