Picsender wont connect to grbl

Everything was working fine until I tried to connect Jtech laser, now Picsender will not connect to GRBL, UGCS will not connect either,I have the correct COM port and baud rate 115200, I tried a different USB cable, nothing seems to work, does anyone have any idea what the problem is

You can only have one program connected to the serial port a time. Once you have a program hooked to the serial port, you have to disconnect that program before you try to hook to it from a different programl

Thank’s Larry, there is no other program connected to the serial port, I have UGCS on the computer but do not use it since I got Picsender, I just tried UGCS when Picsender did not work, it was working fine until I tried to fit the laser, which I had fitted before, I took it off to install Phantoms screw-drive, I may have put a cable in the wrong place at first when wiring the laser would that have done any damage to GRBL

grbl runs on the Arduino/Xcontroller. As long as the Atmega328p chip is not damaged then there wouldn’t be any damage to grbl.

Cables in the wrong place can physically damage the equipment.

Did not work doesn’t give us much to work with.

Can you power everything down and then as you start bringing the system up keep a log of what you do and what the computer/Xcarve does until you get to the place that something fails. Post the log here for us to look for problems.

Which version of grbl do you have installed?

Larry, I power up the Xcontroller then click on Picsender, then select open and get the message USB connection error, I am using your version of grbl 1.0c

Do you have a USB device that you can access using the port that you normally use for the X controller? This would help to isolate where the failure point is.

Sorry I don’t have any other USB devices, I have two USB ports on the laptop I use and I have tried both, I have also tried 3 different leads

I have just tried charging my phone from the USB port and that is working

When the Xcarve is plugged into the USB port does the Xcarve show up under Ports in the device manager?

It shows USB Serial Port (COM3) which I am using and Baud rate 115200

Patrick, when you click on the down arrow beside the com port box in PicSender, what does it show?


It just shows COM3 nothing more

Does Com1 not also show up in the drop down window along with Com3?

Unplug the USB cable from your computer.

Check the drop down window again (click on the down arrow).
What is displayed?

John I have clicked on the down arrow and unpluged the USB cable but it still shows just COM3 no COM1, there are two choices on the Baud rate drop down window, but only one on the COM port box

Use the following walk through to try to get your COM port talking to the X carve. It doesn’t get any simpler than this.

If you can’t get this working then re-install the Arduino IDE and try again.

Next would be to re-install the FTDI driver on the computer.

1 Like

Thank’s Larry, I have decided to get a different laptop as the one I have in the workshop is very old and slow, so I will reinstall everything on the new one, then I will follow the instructions on your link

I have reinstalled everything on a different laptop and followed your instructions but it still won’t connect, I have installed the FTDI driver, I don’t know what to try next, could it be a problem with the X controller

Call Inventables

1 Like

Thank’s Larry, I did contact Inventables and they told me it was a firmware problem and to try re-uploading their forked version of GRBL which worked fine, so I have lost your version, is this version okay for laser work