PixelCNC: generate CNC g-code from images

I’ve been working on a little program called ‘PixelCNC’ to use for taking my wife’s designs and quickly and painlessly generating a variety of different kinds of CNC operation toolpaths from them so I can cut them and ship them out for our Etsy store. I decided to put it online to sell for relatively cheap. There’s a free trial version for people who want to test drive it and see how they like it. It’s available in early-access because I want to see what kind of response it gets from the public before I invest more time and energy into it. It already does everything that I need it to do but if other people find it useful and I could make money working on it then I’ll keep at it.

Check it out here: PixelCNC

Thanks!

4 Likes

Can you define the Free Trial Limit Size of the photo?

The image dimensions (in the trial) are limited to an area of 65k pixels, so 256x256, 512x128, etc… Then there’s the project size, which is the area the image is mapped to in machine-space. You can stretch a 1x1px image over multiple feet if you want, or a 1600x1600 image down to 1"x1".

Will this work with windows XP?

It sure ought too. I haven’t tested it on XP but go ahead and download the free trial and see how things work. It does, however, use OpenGL 3.0, which was introduced 10 years ago. So GPUs will need to be about no older than 10 years in order for rendering to work.

I’d love to hear how it works for you, and any feedback or other questions, good or bad.

Sorry for the delay on getting back to you. I just went through the process of burying my 90 year old mother. I tried it on my xp system and when I tried opening it up it would give the “pixel cnc exe. has encountered a problem and needs to close” message.

Sorry to hear about your mom, may she rest peacefully.

Thanks for letting me know, this could be either due to OpenGL 3.0 or SDL2 being used, or maybe something little. Looking online it appears that SDL2.0 can just crash out on XP. Perhaps I will downgrade to SDL 1.2, which should still do everything that I need from SDL (not sure about that just yet) or fix my own custom version of SDL2.0 that will work for XP. Unfortunately I don’t have an XP machine to test it out on but I believe that there’s going to be somebody out there that knows what the situation is, if it’s SDL2 itself causing the problem.

If you go into your c:\Documents and Settings\[username]\PixelCNC folder, (let me know if you don’t even have one) I’d like to see what’s in the log.txt file in there, if you have one. If it’s SDL2 I should be able to see that that is the case.

I’m not 100% that will be where the PixelCNC user data will be kept. If there’s no folder there maybe try a search for it - there’s also a possibility that when it tries to find where the folder should be created it’s not getting anything back and that may be what’s causing the problem. In that case the problem should be easy to fix!

If you could look into any of these things I’d really appreciate it, I’d love to get it running on XP as I have always been a fan of supporting the widest possible number of user setups, and it has become a bit tricky for me to be able to do that in these later years, but I will do my best :slight_smile:

Take care.

For some reason your message didn’t come through on my E-mail. So just in case you didn’t receive the log file I’m posting it again.log.txt (719 Bytes)

Hi, again. Thanks for sending the log file. It looks like there’s two different problems. First, it’s not finding the current user’s AppData folder where it can read/write user config data and this is because finding it is different between XP and newer versions of Windows, so I just added a check that will have it look elsewhere if need be. However, that’s also where it records the log file, so I’m curious as to where you found it! Secondly, it’s defaulting to OpenGL 1.1 running a Microsoft software implementation, which means either the machine is very old and has extremely limited hardware rendering capability or the (onboard, I imagine) GPU doesn’t have drivers for it installed - so it’s defaulting to the default Microsoft software implementation - which will run at 1 frame per second even if it did work (eww).

I guess at this point the only thing that there’s left to do is determine if there’s any graphics hardware of any kind in there and see if it can be taken advantage of by tracking down some old drivers, otherwise it’s a no go! :frowning: Even if the hardware was too old to utilize PixelCNC’s existing rendering path I could still go in and write a legacy rendering path for OpenGL v1.1, but even if I did that right now it won’t be usable with Microsoft’s software OpenGL renderer.

Thank you for trying to remedy this I found the log in the folder itself named (NULL). Its to bad that it won’t work on my system but that’s the breaks. It looks like some great software. Good luck with your future efforts.

How do i install the free trial to see if this will do what i need and test my learning curv. I AM Getting older and a bit slower.

Ken

All sounds good, but how do i get the trial version to try? I AM GETTING older and slower. This sounds like what i need!!

Ken

Download and install from: https://deftware.itch.io/pixelcnc

OK, tried the link and same download page i had before. I tried to download each trial one at a time and still will not load, says could not create GL context file.

Have you downloaded this program and if so does it work for you??

Ken

If PixelCNC cannot create an OpenGL context then your computer is probably just too old. PixelCNC utilizes graphics processing hardware which has been built into virtually every new computer or laptop that has been made in the last 10 years (inexpensive budget Windows netbooks included). PixelCNC uses the graphics compute hardware for both drawing its interface and also performing toolpath-generation calculations. It was designed from the ground up to utilize modern hardware and features (graphics compute, multi-core CPUs, etc).

Can I ask what computer you have, make and model? Do you know what is in it at all? You might be lucky and just need to install the driver software that enables Windows to provide applications with an interface for utilizing whatever graphics hardware is present. If your machine was made before ~2008ish you’re probably out of luck :frowning:

Charles,
I don’t know if i replied to you on the right page. Grandaughter interupted me. I am running windows 7 home premium 32 bit on a 2011 built by milwaukee pc. They suggested the same thing. I might only need the drivers downloaded etc. They no longer have the build info on my pc. I had it built for my construction business and home desige, estimates, material calcs, etc. I pulled it out of my closet last year when i started in the cnc world.
Hope this helps???

Ken

I’m able to surf MilwaukeePC’s site from back in 2011 via Archive.org and see what machines they had. I don’t see any running the 32-bit version of Windows Home, except for their home server machines, which are running Windows Server Home 32-bit.

We can narrow it down with the CPU, amount of RAM and the harddrive capacity.

http://web.archive.org/web/20110129204431/http://milwaukeepc.com:80/ViewSystems.asp?SPTID=628#

http://www.notebookreview.com/howto/identify-pcs-hardware-specifications/

i found this info in system info

32 bit OS
1.0 GB
PENTIUM 4 CPU 3.20 GHZ
HARD DRIVE 111 GB WITH 54.7 GB FREE SPACE

hope this helps. most of this is a learning curv for me.

Teach an old dog new tricks
Grateful thankyou to you
Ken

sorry Windows 7 home premium

Thanks for your patience,

Good news and bad news. switched to a laptop i had and the and thr download worked. Now the bad news, no matter what image i try to load it tell me file to big. Now what do i need to do???

Ken