Placement is off

I just got my X-Carve hooked up to my computer( Big thanks to the awesome @LarryM ) and had to tighten my belts a little and my X and Y axes were moving in the opposite directions and homing was in the wrong corner, so clicked the button during Easel Setup to change GRBL settings so they’d be correct.

I then went to do my first carve, and the below (short) video is what is happening. I set my work area and material to the size of the scrap wood piece. But X-Carve moved to the middle of the board.

Is this another GRBL setting or something I’m missing? I did do a homing prior to starting in the front/left corner of the piece of wood

Since the grbl parameters for number of steps per mm was way off I’m not surprised that your cut was bad. Try it again with the new parameters I sent to see if it works better this time.

Also, you need to set work zero on your machine. Do you know how to do that?

From your reply at this thread, below is the $$ info now:

$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000011)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.050 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=1 (soft limits, bool)
$21=0 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=500.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=188.976 (z, step/mm)
$110=5000.000 (x max rate, mm/min)
$111=5000.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=250.000 (x accel, mm/sec^2)
$121=250.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=790.000 (x max travel, mm)
$131=790.000 (y max travel, mm)
$132=100.000 (z max travel, mm)

Edit: I popped over to Chrome and could home the machine. Did my first carve and it actually carved on the board, but not exactly where I had placed the design in Easel. Is there a certain setting used to dial it in more? Also after doing the one carve, I tried to move the axes again with the arrows in Easel (when you click Carve) and not working anymore…

My 1/8" collet hasn’t come in yet, so I only have 1/4" bit, so trying to find simple designs that can handle the larger bit. So I just did a basic small heart.

And this is how it came out…

I’ll have to defer the Easel questions to someone else because I don’t use Easel and don’t know much about it.

Grbl parameters look good.

This looks like you are missing steps in the stepper motors. Usual causes are:

V wheels not adjusted properly
Belts too loose or too tight
Stepper motor current too low

Check your adjustments on the gShield current limit potentiometers. To start out your testing - set them like the ones in this picture. This is for the NEMA 23 motors that Inventables sells.

Well, I would definitely try the above as that’s a mechanical issue not a Easel issue. My guess would be loose V wheels by the look of it. But from the Z axis issue milling to deep, that looks like your pots are to low. It takes a while to get the machine dialed in right so don’t get frustrated, walk away clear your head and start over. If you just tightened your belts go back and tightened them again, the belts stretch a lot when there new. Between the three you will get it working. Quick question did you remember to choose 1/4 in bit on the selection and not 1/8"?

I’ll check those potentiometers (never used that word in my life) settings when I get home tonight.

And when doing the belts, in my searching I can’t seem to find a guide that defines the correct tension. I just see “adjust the belts to the right tension. not too loose to too tight”. Is this just an experimentation thing? I saw one guy using a luggage scale to measure tension in pounds?

And I made the eccentric v-wheels tight enough so that they don’t spin with your finger, only when the axis moves. Isn’t that how they’re supposed to be?

Edit: I remembered I had taken a picture of my gShield for another forum post, so can see the potentiometer settings appear the same. I do have the NEMA 23’s

Also, I did put calipers on the bit I was using and set it as the bit size. Is there somewhere else you have to change to make it go with 1/4" vs 1/8"?

So far the only information I’ve seen is that the belt tension is somewhat a seat of the pants adjustment. Some have tried to quantify it with a scale, but it really comes down to what works on your machine. The idea is to adjust them tight enough so that you don’t get missed steps, but not tight enough to cause excessive belt wear. Right now I’m using a pen and ink test setup so I don’t have side loads on my machine and my belts are just tight enough so that they quickly return to their resting position when “plucked”. I’ll have to tighten them a bit when I start carving with a spindle.

From what I’m reading on the forum you may have your V wheels a little too tight. Most people try to adjust them so that you can turn them with your finger, but with some effort to do so. Obviously any wheel that stops turning anywhere along the axis is too loose. You need to do this adjustment without a spindle loaded and without tension on the belt as that tension could interfere with the adjustment.

The pots (shortened term) in your picture look fine for starting. If you are missing steps then you may have to nudge them up a bit. Especially on the Y axis because there are two motors in parallel so each one only gets half the current (but half the load as well).

I know that this is all a bit wishy-washy, but there isn’t a lot of definitive information on these topics.

I can give you a method for setting the current limits exactly. It requires a voltmeter and working in a tight spot on the gShield. Let me know if you want that info. It’s on the forum somewhere, but I forgot where it is.

I tried making my Y belts have the same “pitch” when plucked (Inventables support said to make it so it makes a sound when plucked) and also adjusted all my V Wheel so that with some force, I can spin them with my fingers (previously were so tight, they couldn’t spin by hand, only when machine was moving). I tried to do a simple carve (box border with 2 slight angles on the long sides).

I carving came out to pretty much just a square border. During operation, I did notice the Y axes seemed to move slightly off from each other. The right axis (video is upside down) seems to move a little before the left.

Am I missing something in my calibrations?

Edit: Just tried another simple carve (4 lines at different angles) and the lines appear correct in regards to the specified length and are straight. however the entire machine carved it about 1/2-3/4" to the left of where it was supposed to be carved.

The twist in the Y direction should not happen.

Make sure the screws in the MakerSlide on each end of the Y axis are tight (once again the instructions are not clear – they say moderately tight - what does that mean?). Don’t tighten too much you’ll snap the head off the screw. Just check them to make sure they’re not loose.

Check your motor wiring on the Y axis to make sure the wires are not loose and no strands are shorting to their neighbor.

Up the current limit on the Y axis, just turn the pot up about the width of the screw driver slot in the top of the pot, not to the half way point.

Check the design and your selection of Work Zero. I believe in Easel it shows the spot where you should set Work Zero, and if your design is offset from that position in the design, then it will be offset in the carve.

Checked the screws and they aren’t going anywhere. I also installed them with some blue Loctite so they should stay put.

I put photos of my wiring in this other post

From checking, it all appears correct. So guess I just need to increase the current to the Y axis? A photo of my gShield is also on that post. Out of the 3 white boxes with screw heads, is it the MIDDLE one that adjusts the Y axes? (the one to the LEFT of the Y axis letter)

Yes, it the one just to the left and below the Y on the silkscreen.

So all belts make a sound when plucked
I turned the Y potentiometers up the width of a screwdriver head
All maker slide self tapping screws are tight

Here is my test carving.

1st carve on left done yesterday before pot adjustments: The lines are crisp and clean, but the entire design was done ~1/2" to the left

2nd carve on right done tonight after adjustments: The horizontal is exactly where it was supposed to be, 4" from the left edge of the wood, but the lines are really sloppy and it’s higher than it’s supposed to be.

What else is off? I turned the pot under the Y silkscreen clockwise just a little bit

Edit: I reset the trimpot and then bumped it up a little bit on the Y axis. Then checked all v-wheels again, loosening them so they weren’t as tight. It looks to have done the 3rd carve more precise. Location seems to be exactly where it should, and lines appear clean! Guess that means it’s time to do this a few more times to make sure it’s consistent.

@LarryM after doing your GRBL changes, homing cycle goes REALLY slow on the X and Y axes now. Is that part of the setting? I thought I remembered it going fast, like the Z axis does

This is the homing seek rate that is the default for the X-carve. You can change this rate to make it faster. The trade-off is speed versus safety. What happens if the rate is too high is that your spindle carriage may slam into your switches and break them. Too slow is that it takes a long time to home the machine.

You can play with the value to find a rate that seems reasonable to you that doesn’t cause it to hit the switch too fast.

The things you are doing to make the carve better are the steps for dialing in your machine. You have seen the effects of the changes you have made and now you have the experience to move forward to the point where you like the way your machine works.