Port problems

After a week of cutting with xcarve, my laptop windows 7 no longer will communicate with xcarve. The com port on my computer is 4. Arduino is giving me a keyboard message “board at com6 is not available”. What can I do? I have tried everything.
Gene Nixon

Windows seems to have a way of wanting to change the port designation at times. It might be due to plugging and unplugging other USB devices. I haven’t taken the time to try to determine why it does it. My Arduino has shown up as everything from COM3 to COM7. If I get an error message, I double check Device Manager and change the COM to whatever it needs to be.

as long as you use the same usb port it should stay the same but device manager sounds like the solution!

Under device manager, I don’t see where you can change the port. It says it is set under 4.

I change the software to match Device Manager; i.e., Easel, UGS, whatever you use to send code toArduino.

Gene, you can’t change it in Device Manager, you have to change it in Easel. Use Windows Device Manager to figure out which com port Windows assigned to the Arduino used by your X-Carve (port 4 in your case, today), and then, in Easel, go to Machine, -->set up your machine and you should get a prompt to set the com port.

Some people’s computers will always put the Arduino on the same com port, but mine has a tendency to randomly assign it to different com ports for no apparent reason other than the fact that I have lots of USB devices, including other Arduino based gizmos that stumble over each other to seize a com port.

I have done as you suggested, but when I enter com4, which is what windows has assigned to Arduino, it will not connect. I then check the Arduino file, open the file and it gives me a message Arduino’s com is on 6.

OK Gene, I completely feel your pain. Easel probably is just reporting the last com port assignment that you gave it, not the ACTUAL com port that windows assigned to the Arduino. You set it to 6 at some point, so it reports 6, but then windows assigned arduino to port 4, so now you have to change Easel to port 4 …so you probably shut off the computer or disconnected the usb cable or plugged in a flash drive or your camera, or who knows what at some point and now Windows has assigned a different com port. It’s now port 6, so you have to tell Easel that the machine is NOW on com port 6. Unless you have done something else with your computer in the mean time, so you have to check device manager AGAIN…grrr…and then tell Easel…Again…

You should not be doing anything at all in the Arduino IDE. Easel runs that in the background, and only because it needs the drivers…I think. So if you have the Arduino IDE open, close that puppy and only use the com port selection dialogue that is in Easel.

Next time it might change to port 7, or 11, or 3, or something else. Arduino and Windows just do this, it’s not the fault of the X-Carve or of Easel, it’s actually somewhere in the hardware bus I think, but that doesn’t make it any less annoying I know.

I am told that the next version of windows will solve this problem, but for now, you just have to do it this way. It’s a problem that anyone who has been playing with Arduino for the past few years has encountered, and you just get used to it.

Bottom line, go into devices, and see which port Windows has assigned to Arduino, then open the “Machine” dialog in Easel, click “Set up your Machine”, and type in the com port number that you just saw in device manager.

If that doesn’t fix it, you have a problem beyond my kenning.

Thank you for your help.

I’m having a similar problem. Setting the same port in Easel as Device Manager shows, but still nada. What is the Arduino file you’re checking to see what it thinks is the correct COM port?