Power light

Hello I cant seem to get power to the x controller
stop is disengaged but green light is not on.

Really twist the E-stop, it should snap out. There have been reports of others that the E-stop was indeed engaged while the operator “was certain” it was disengaged.

still no lights internal fan and router both work

Press down on the Estop and see if it engages. When i first got mine it was very tight. I had to twist and give a Hearty pull up at the same time to get it to disengage. If that for sure doesn’t work you may have gotten one out of the bad batch they were sending out. Give the help desk a call.

You gotta man-up on that Estop and pull man pull! :wink: (not too hard though)

I have heard the connections to the E-Stop are not that great . Start there

That too :slight_smile:

I had that problem when I first built mine, fan was working etc., e-stop was working and I could start stop the program in easel but no lights and buttons didn’t work on control box.
I took my control box cover off and made sure my connections were firm as I thought they were, as soon as i re-snugged the wire from the front face plate and re-assembled, viola! I had power light and buttons worked, try that :wink: