Inventables Community Forum

Probe failure bug

Over the weekend, I have used my X-Controller (1.0c firmware) and Easel with the new probing feature. It worked fine the entire time.
I can share my setup (wiring or software) if anyone has any questions.
FYI, all I did to get it working was run the Easel Setup.
The only “issue” I had was I had to re-calibrate my Z axis inside GRBL’s EEPROM due to me running a custom threaded rod, but this was excepted on my part.

Not recently.
Why is UGS probing special vs Easel probing?
Don’t both simply a send gcode command?
Regardless, what version of UGS should I try with?
And as a bonus, what gcode would you like me to send (besides a simple G38.2 command)?

One thing that came to mind is that I might have downloaded and installed the 0.2.7 version of Easel Local when the 0.2.6 version was still marked as the “current” version. Is there a chance the 0.2.7 version changed after it was posted to the download website, but before it was marked as current? I’ll try reinstalling that and see if it helps.

1 Like

We are going to have an official response on this posted to the forum. We have a team working on this it is a very urgent issue. Please stay tuned. In the meantime if you need help urgently contact us online or call 312-775-7009 and someone in our Customer Success department can help.

2 Likes

In the meantime, can someone confirm that the Inventables probe socket closes the connection when the probe is unplugged? That would explain a lot.

@PhilJohnson What issue are you having with the hex file:
downloading the hex file?
flashing?
Not working when flashed?

A separate thread for downloading the hex may be appropriate.
I just downloaded it and flashed my Arduino with it, upgrading it to 1.0c.
I would post the file only as a last resort. Spreading multiple copies around just makes things messy, especially when other people require help, vs going directly the official Inventables github page.
EDIT the X-Carve EEPROM defaults for those curious:
Grbl 1.0c [’$’ for help]
$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000011)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$30=12000. (rpm max)
$31=0. (rpm min)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=188.947 (z, step/mm)
$110=8000.000 (x max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=500.000 (x accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=740.000 (x max travel, mm)
$131=790.000 (y max travel, mm)
$132=100.000 (z max travel, mm)

Obviously they will change once you run Easel’s setup to match your appropriate hardware.

So Inventable’s support got back to me tonight concerning the error report and suggested a reflash of GRBL onto the Xcontroller so I just did that and it fixed the problem. It works as it was intended to work.

They mentioned an official response with more details about what happened will be posted, as Zach previously mentioned.

The support article I was given for reflashing was:

https://inventables.desk.com/customer/portal/articles/2058884-how-do-i-re-flash-grbl-to-my-arduino-

I followed the steps and it worked. My GRBL settings from the previous 1.0c were not changed and persisted across the flash.

I also double checked UGCS and 3 axis probing since I have the Triquetra and, as before the flash, it is also working still.

3 Likes

Yeah. Fixed my issue too. Just did it now.

When you followed the link from the firmware flash page to the github repository, did you stay on the master branch and download that, or did you switch to the 1.0c branch and download that?

I followed the instructions to the letter

From the recently updated screenshots I see that it’s the master branch, but as someone who uses git for work on a daily basis the branch to check out should be specified in the instructions. It would have been completely reasonable for someone to think that the 1.0c branch should have been used.

Yes still works. Both x controller and gsheild too.

1 Like

Hi All,

We are really sorry for the issues you have been experiencing with using your Z-Probe. The issue is occurring because an incorrect version of our firmware was pre-loaded on the controller boards, producing an error on how pin states are reported.

To load the correct version of the firmware please follow the steps outlined in this support article.

We will be posting a way to load firmware through Easel shortly. We will give forum users a chance to test this out before we make it available to the wider public. We are hoping to post an update on this sometime tomorrow.

Here at Inventables, we take these kinds of problems seriously. We are investigating the situation to better understand how the incorrect firmware was introduced in the first place, why it was not caught during testing and how we can prevent something like this from happening in the future.

Thank you for your patience and continued support of Inventables. We are thankful to have you as customers, and apologize for the inconveniences we have caused.

Sincerely,

The Inventables Team

3 Likes

I flashed my Xcontroller the other night however, now, looking at the commit history, there is a change to grbl.h which changes the build date but nothing else appears to be touched.

Do I need to reflash? Seems like it’ll just be helpful for error reports/customer service as opposed to functionality but if Easel is looking for a particular build date, I may need to reflash.

1 Like

Reflashing didn’t fix it for me. The setup now works, but when I try to start a carve in Easel I can’t get past the “plug in the probe” step. I’m not using the Inventables probe so I don’t have a socket to plug into - the probe is permanently attached to the X-Controller.

1 Like

@StevePrior if u touch the probe to clip it will show up as plugged.

@PhilJohnson i followed the instructions. Im not good with these little arduino stuff but their directions fixed my issues. Was not that complicated. Especially for someone like u.

You can grab the hex file here: https://github.com/inventables/grbl/releases

Hi Justin,

Easel does not look for a build date.

The results are the same. The difference is that with the Arduino IDE you are compiling grbl right then and there (which produces a .hex file that the IDE then uploads to your arduino). A .hex you download is precompiled so you just need a program that flashes arduinos (theres a bunch out there like XLoader or @paulkaplan 's HexLoader )…

1 Like