Probe test on Arduino

Since you have to change firmware anyway - try the version of grbl that I posted for the laser group. It has a lot of testing on it and that’s the version I’m testing with.

Here’s the link if you want to test with it:

https://discuss.inventables.com/t/xcarve-jtech-grbl-update-bug-fix/28943

Post or send me a PM when you start testing and I’ll try to work with you to get it going.

1 Like

I got it to work. Basically made the upgrade to Easel, grbl and arduino as Erik just outlined. In order to upgrade my arduino (flash to 1.0c), I had to remove the g-shield, otherwise I was getting an error. And as Larry M pointed out, the Advanced Settings button on the Z-probe set up page is where you’ll need to enter the height of your touch plate.

It’s definitely not as simple to set up as it could be, but like everything else, once you get it working, it seems to keep working.

Sorry, but I’m not able to follow the g-code discussion ($6=…) But I can say that I believe my machine had the original settings (mid 2015). I can’t remember the pin I’m using to connect to the arduino, but it’s the same one listed in all the instructions out there that I found at one point.

1 Like

Do you know how to remove programs from your system using the control panel selection “Programs and Features”?

If so, remove Easel local before you start your testing and re-install it from the web site.

1 Like

Are you seeing this page when going through the machine setup?

These are the instructions I followed… Jump to the “Z-Probe Computer Set-up” section at the bottom.
http://x-carve-instructions.inventables.com/upgrade/step4/

I found it, I overlooked the Advanced Settings button, after Yes you get into the setup menu of the probe, where you can define in detail your probe settings. This worked. So I can confirm a probe works with grbl 1c and an Arduino UNO.

Sadly my settings are back to standard too. Is there a possibility to adjust the probe setting without touching the rest of the settings? This would mean that if I want to correct my probe tolerances I have to adjust my settings.

I think you can access that going to Machine -> Advanced. I’m currently not at my machine to check.

I haven’t changed my grbl settings, or I haven’t had to send any grbl code - so my situation may be different. What do you see after the “Do you have a z-probe” screen? I may have had the same problem as you, seeing nothing, but I can’t remember the exact steps to fix it.

Yeah, that’s bad. I think we need to do some testing outside of Easel. It appears that you have a fundamental problem which is preventing Easel from “following its procedure”.

At that point in time we probably should have a conversation about that.

1 Like

Here are my settings on a fresh build of 1c hopefully you will figure out what is different in your situation Phil,
500mm SO2 with OpenBuilds ACME and max travel on X and Y

**** Connected to COM3 @ 115200 baud ****

Grbl 1.0c [’$’ for help]

$$
$0=10 (step pulse, usec)
$1=25 (step idle delay, msec)
$2=224 (step port invert mask:11100000)
$3=7 (dir port invert mask:00000111)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=1 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$30=12000. (rpm max)
$31=0. (rpm min)
$100=40.020 (x, step/mm)
$101=40.020 (y, step/mm)
$102=266.667 (z, step/mm)
$110=800.000 (x max rate, mm/min)
$111=800.000 (y max rate, mm/min)
$112=800.000 (z max rate, mm/min)
$120=100.000 (x accel, mm/sec^2)
$121=100.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=330.000 (x max travel, mm)
$131=330.000 (y max travel, mm)
$132=50.000 (z max travel, mm)
ok

Yes I can confirm my probing in easel works. And my macro in UGS too.

I noticed that the grbl settings are not always updated when flashing. Seems it does with a higher grbl version but not at re-flashing at the same version level.

During setup Inventables writes to grbl, in my case in setup I chose ShapeOko1-2 not X-Carve

I wonder what made the big mess about probing, at the end it proved a pretty simple straightforward process, basically the only real problem I had was the pitch of my ACME rod.

Arduino UNO with the above settings:
Probing

Just got a response from the Inventables support desk:

With the gShield it’s a bit more difficult to configure than the X-Controller, but it should be similar. I would try upgrading your local sender version to 3.1, also you might want to re-flash your firmware depending on the when the last time you did so was. We recently made some changes addressing some bugs with the probing.

Hopefully you will get this up and running soon.

I just flashed and ran through the setup again, the probe is working perfectly. Now I love my 1-2-3 blocks even more!

When did you get this response?

I received the above message OCT 24, 2016 | 04:33PM CDT

Upon my acknowlegement that my probe is working now I got the following message OCT 25, 2016 | 03:14PM CDT expressing the mission of Inventables to support us. With the new role in software development (Easel) and system integration (grbl) and Software as a service it is obvious that like us learning CNC Inventables is in a steep learning curve to deliver us these products.

Hi Erik, glad you got the issue sorted out. X-Carve is and will always be an open source machine- this is something we are committed to and we will do our best to support older and newer machines alike. We are attempting to keep as many upgrade packages as we can in stock and provide the necessary information to use them, though with the recent upgrade we’ve been somewhat slow to get the more specific ones out. We will hopefully be introducing more products like this in the next few months. Thanks again for contacting us. Please let us know if you have any other questions.

Fair enough, looking forward to these new products.

Thanks, for that information.

You’re running XP right? Newer Windows versions handle driver switches much better than XP. You’ll probably need a reboot when you upgrade/downgrade (as in uninstall, reboot, install, reboot).

1 Like

Easel sets the $10 value in setup your machine, for ShapeOko 1or2 value = 3, for X-Carve value = 115 on my Arduino there is no difference in behaviour.

Final test, I modified the ShapeOko2 deffaults to match my settings, modified config.h to use these defaults, disabled the safety door and pull-off and re-flashed my Arduino UNO.

Probe in Easel still works regardless if I define my machine as a ShapeOko2 with gShield OR XCarve with X-Controller.

Seems like that yes, nor safety door at least against the Easel of today. Configuration does not seem to matter whatever choice you make.