Probing suddenly not working?

I had an issue where Easel stopped asking me to probe the work during the carve stage.

I set up the machine again and reminded it that I had a Z probe, and that seemed to work. I ran it again, homed the machine, jogged it to the spot where I wanted to cut, got the probe questions and successfully probed the work.


Now it goes through the process, asks if I want to probe, shows contact when I touch the bit to it, and looks for all the world like it’s about to probe, but when I tell it to “Start Probing”… nothing. The screen looks like it’s probing, even SAYS it’s probing, but it’s not.

These two instances were less than 5 minutes apart. Worked perfectly, five minutes later, after doing nothing but jogging and homing the machine, it won’t respond to a probe command. The Z works perfectly in the home command and in jogging, but for some reason ignores the probe command.

Tried this in Opera, Chrome and IE with identical results.

Any ideas, O Great Community of X-Carve?

First I would check the wiring path of the probe. I have read reports of the socket not making good connection with the probe wire to the mill.

checked my wiring, but the probe wiring wouldn’t keep it from moving down to try and touch the plate would it? The spindle isn’t moving when I hit “probe”

is this on a new machine you just built or the one that you sold?

This is on the one I sold. I was setting it up to make some cuts when the buyer comes tomorrow. AWESOME timing.

right lol

hmm the only thing I can think of is there must be a loose wire somewhere especially because it was intermittent in the beginning

If you use the Inventables Z probe socket, then yes it could. The socket is a normally closed socket so it would appear as an immediate trigger of the probe. Doesn’t explain why it gets stuck though.

1 Like

What firmware version?


Maybe this will help. Machine inspector shows an alarm state. Clicked “Show Status” and got a constant rolling feed like this:

Do you have home switches and configured to use them?

Every time you disconnect the USB or open and close Easel, you have to home the machine.

Also, did you enable soft limits recently?

Yes I do, and I home every time I turn the machine on.

Also went through the homing process every time I’ve tried to probe during this problem, as it’s part of the hold-your-hand Carve walkthrough.

Soft limits enabled?

Easels probe command is like the entire axis and it doesn’t play nice with proper soft limits and spindle locations.

Yes, soft limits enabled. I thought about that and went into Machine Inspector and tried to disable them but it wouldn’t change them. Could that be because of the alarm that was evidently being sent constantly? (That is what I’m seeing with the continuous rolling screen of alarm messages, right?)

Type in “$h” to home to clear the alarm then disable soft limits then try probing.

Also, the alarm isn’t being sent, the “heartbeat” that Easel does just reports the machine status which is “alarm”.

1 Like

It looks like that did it! Shame, as I really appreciate soft limits.

Thanks very much to all who replied!

1 Like

I would report this to Inventables as a bug in Easel. Easel should work with soft limits.

I agree!

I set my z soft limit to a larger value and it was all good

I agree but, I’ll tell you why Inventables won’t change anything.

The Z probe command they send has a potential max travel of the entire Z axis. The reason for that is they are coding so that it works no matter who does it or where it starts. A lot of users will move the Z close to the probe prior to starting the probe, as that makes sense to do. However, there will be a decent amount who expect to be able to launch the Z probe immediately after homing which means they start from the top of the axis. With no real knowledge of where the Z is (hence the probing), they are coding for the absolute worst case of probing, starting right around Z=0 instead of like a 0.25" on top of the probe.

Is this smart? No. But unfortunately, it’s probably needed. That is unless you have training material available that will show best practice is to jog the spindle close to the probe prior to probing.

That seems to be the way the Carvey does it, it goes X0Y0 then moves to a point above the switch and then lowers to the smart clamp from the top of Z.