Problem during PCB milling

Hi,
I was trying to do PCB milling and I could find two projects in inventables about PCB milling.I followed the steps as mentioned. Created a gerber File using Eagle and used FlatCAM to generate gcode. Next step was auto leveling using Chilipeppr. It was my first experience with chilipeppr and I faced my first trouble here, I couldn’t do auto level because bit stopped moving even before it touched the PCB . Then I found out it was due to noise. So I twisted the probes and things became normal and I could do auto leveling without any trouble. But when I sent the leveled gcode for job, machine came to zero position and started moving as it was supposed to do but it is not touching the PCB surface. It just moves around the surface with tiny gap between board and bit (gap is so small) . Result no engraving.
I tried it several times but still no use.
I am using GRBL not TinyG and my threaded rod is M8.
I don’t know which is the default z axis parameters in chilipeppr and I couldn’t find any provision to change the screw type in chilipeppr( in Easel there is an option to choose the rod M8 or Acme).
Seeking all advice and opinions about solving this.
Thank you

Try my way https://www.inventables.com/projects/easy-pcbs-on-the-x-carve it’s simple

But I want to use the autolevel function because my bed and PCB not exactly in level with the axes

I found that if you connect the A5 pin w/ a resistor to the mill bit, you will get ALOT of noise. It may actually look like it is connecting for parts of the board but not for the rest.

My suggestion is to make sure you connect the wire from A5 w/ a resistor to the PCB board, and have the ground pin connect to the mill bit. This doesn’t appear to have any noise issues running it this way.

A second thing you want to check is to make sure in Flatcam when you are in the “Create CNC Job” that you are setting the Cut Z value to (-0.07 ~ -0.1) when generating the gcode.

Also, make sure you tape down the PCB to prevent it from moving on the Z axis, this could be a problem if auto-leveling is working correctly.

Hopefully one of those solves your issue. Let me know if you are still having trouble.

1 Like

@Bala
Hey thanks for the reply.
w/ a ??? I didn’t understand what it meant.
As explained in the project I connected one wire to A5 and other end connected to bit using a clip
and second wire from PCB to GND. Isn’t this the right way??? Should I connect it in reverse.??
I also found a lot of noise.
First time I used it with out a pull up resistor and it was awful. I thought it was a problem in Chilipeppr and posted it in there community. Their reply was it’s a hardware issue.
Second time I used a pull up resistor of 470 ohm, and got the first mill accurately but the remaining ones weren’t good.
Then used a capacitor of 1 uF between A5 and GND with and without pull up resistor but it wasn’t good either.

Then I had no choice but to reduce my pull up resistor value, and it destroyed my arduino.

Now I am using a pull up of 470 ohm and a bypass capacitor of 0.1 uF, and I am getting good results but it also has problems sometimes.
The probe I have now is not a good one , I think if I change that ,it’ll improve the results.

Now I will try your suggestion.
Thanks