Problem flashing arduino

I am getting error problem uploading to board (the error message is copied below)

I followed the instructions by downloading arduino 1.6.9. the arduino port shows up in device manager and i have arduino set to that same port.

**I also can’t upload blink example as a test, so think it’s an arduino issue

Arduino: 1.6.9 (Windows 10), Board: “Arduino/Genuino Uno”

In file included from C:\Users\u\Documents\Arduino\libraries\grbl/grbl.h:43:0,

             from C:\Users\u\Documents\Arduino\libraries\grbl\examples\grblUpload\grblUpload.ino:27:

C:\Users\u\Documents\Arduino\libraries\grbl/nuts_bolts.h:25:0: warning: “false” redefined [enabled by default]

#define false 0

^

In file included from C:\Users\u\Downloads\arduino-1.6.9-windows\arduino-1.6.9\hardware\arduino\avr\cores\arduino/Arduino.h:24:0,

             from sketch\grblUpload.ino.cpp:1:

c:\users\u\downloads\arduino-1.6.9-windows\arduino-1.6.9\hardware\tools\avr\lib\gcc\avr\4.8.1\include\stdbool.h:42:0: note: this is the location of the previous definition

#define false false

^

In file included from C:\Users\u\Documents\Arduino\libraries\grbl/grbl.h:43:0,

             from C:\Users\u\Documents\Arduino\libraries\grbl\examples\grblUpload\grblUpload.ino:27:

C:\Users\u\Documents\Arduino\libraries\grbl/nuts_bolts.h:26:0: warning: “true” redefined [enabled by default]

#define true 1

^

In file included from C:\Users\u\Downloads\arduino-1.6.9-windows\arduino-1.6.9\hardware\arduino\avr\cores\arduino/Arduino.h:24:0,

             from sketch\grblUpload.ino.cpp:1:

c:\users\u\downloads\arduino-1.6.9-windows\arduino-1.6.9\hardware\tools\avr\lib\gcc\avr\4.8.1\include\stdbool.h:43:0: note: this is the location of the previous definition

#define true true

^

In file included from C:\Users\u\Documents\Arduino\libraries\grbl/grbl.h:43:0,

             from C:\Users\u\Documents\Arduino\libraries\grbl\examples\grblUpload\grblUpload.ino:27:

C:\Users\u\Documents\Arduino\libraries\grbl/nuts_bolts.h:54:0: warning: “max” redefined [enabled by default]

#define max(a,b) (((a) > (b)) ? (a) : (b))

^

In file included from sketch\grblUpload.ino.cpp:1:0:

C:\Users\u\Downloads\arduino-1.6.9-windows\arduino-1.6.9\hardware\arduino\avr\cores\arduino/Arduino.h:85:0: note: this is the location of the previous definition

#define max(a,b) ((a)>(b)?(a):(b))

^

In file included from C:\Users\u\Documents\Arduino\libraries\grbl/grbl.h:43:0,

             from C:\Users\u\Documents\Arduino\libraries\grbl\examples\grblUpload\grblUpload.ino:27:

C:\Users\u\Documents\Arduino\libraries\grbl/nuts_bolts.h:55:0: warning: “min” redefined [enabled by default]

#define min(a,b) (((a) < (b)) ? (a) : (b))

^

In file included from sketch\grblUpload.ino.cpp:1:0:

C:\Users\u\Downloads\arduino-1.6.9-windows\arduino-1.6.9\hardware\arduino\avr\cores\arduino/Arduino.h:84:0: note: this is the location of the previous definition

#define min(a,b) ((a)<(b)?(a):(b))

^

In file included from C:\Users\u\Documents\Arduino\libraries\grbl/grbl.h:43:0,

             from C:\Users\u\Documents\Arduino\libraries\grbl\examples\grblUpload\grblUpload.ino:27:

C:\Users\u\Documents\Arduino\libraries\grbl/nuts_bolts.h:58:0: warning: “bit” redefined [enabled by default]

#define bit(n) (1 << n)

^

In file included from sketch\grblUpload.ino.cpp:1:0:

C:\Users\u\Downloads\arduino-1.6.9-windows\arduino-1.6.9\hardware\arduino\avr\cores\arduino/Arduino.h:115:0: note: this is the location of the previous definition

#define bit(b) (1UL << (b))

^

Sketch uses 30,072 bytes (93%) of program storage space. Maximum is 32,256 bytes.
Global variables use 1,507 bytes (73%) of dynamic memory, leaving 541 bytes for local variables. Maximum is 2,048 bytes.
avrdude: ser_open(): can’t open device “\.\COM5”: Access is denied.

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences.

Do you have easel or another program open that is connected to the X-Carve?

Check if you are on a USB 3.0 port (usually blue inside), if so try a USB 2.0 (but see if the com changes though.

This looks like your Arduino IDE installation is corrupt. Uninstall and re-install the IDE.

Which version of grbl are you trying to build?

Post your application settings under the port as well.
The last error said it could not communicate with the board.
Also make sure the drivers are working by uploading the blink example first and if that works then you can move on to the GRBL
The blink is a default small app that you can use to test if your computer can upload successfully.

ya he said blink doesn’t work, Maybe a bad cable, bad uart, bad port, bad drivers, or not really on the port that it says. gotta get blink to work. Heck, if the OP is in south central PA, I have uno’s everywhere he could try.

Guess that’s an contradiction or oxymoron? many unos

I have had issues similar and it was due to the drivers.
Not sure as it could be any as Mike suggested.

1 Like