Problem starting cut after zeroing with ugs

I just plugged back my xcarve and I have trouble starting my cuts after zeroing… I use Fusion360 for Cam & post process and UGS 1.0.9 to send the gcodes to the xcarve. After zeroing through the machine command tab, I visualize and then press send. This is where the problem pops up! When it starts to go to the first plunged position, the router mooves down as it goes therefore milling materials it shouldn’t. I don’t have limit switch so I use UGS to set the machine position & work position. Did someone experienced such problem & what would fix it? I’m stocked to finaly have a soundproof place to use the machine, but that’s my final step before being able to enjoy it! Thanks

To eliminate any workflow issues could you test a simple shape made in Easel only?
No Fusion, no post process.

You can also post the first 20-30 lines of gcode from your .NC-file for us to look at.

I will try Easel tonight if that could help. Here are the first lines of my nc files. Do you want me to do the same with grbl menu in ugs (aka: $$)?

In your code you have a G28 command, this is a pre-set position which can be anywhere in space.
Are you familiar with G28/G30?

Thanks guys that that did it! Do you have another trick in your sleeve to disable the up/down movement prior to the first plung? It seems to mess up the cut depth of the first pass. Hopefully one day i’ll be ontop of those problem like you both!

1 Like

Under your Fusion360 CAM -> Main Setup pane, do you have a 1mm stock top offset active?

1 Like

Nop that part I got right…Do you have a website that explains who to read the .nc files? I doubled check that my x-carve is calibrated 1 jog = 1mm by example on x, y & z axis and it’s good from what I can see. The Zmin is the thickness of my sheet…

Is there a way to delete the up/down motion prior to the first plunge?

The toolpath is also good from my point of view, here’s a look (3 pass of 1.5mm cut):

Any ideas? Thanks guys

On line 10 you have the command T1 M6.

Grbl does not support the M6 command (causes an error) and some people have experienced problems with the T1 command.

You don’t need either for the X-carve. You may not be using the correct post processor.

I think I found my problem, I’ll try to fix it and let you know!

If your fix doesn’t work you could try one of these post processors to see if that would work for you.

Hi guys, I resolve my Z axis problem, but another popped up about 1h into my cut…
It’s the second time it does that for that cut… Everything’s fine until around the 1 hour mark when the Y steppers motors starts skipping for about 4-5 second which leads to this…

There are no obstruction to the router’s path, so I’m wandering what could cause this? Any ideas?

Either RF noise due to static electricity or the Y-driver is overheating and goes into thermal protection. The latter is more likely. Gshield or Xcontroller?