Problem with DIY CNC Y axis

I am not sure if this is the right site to ask questions about a DIY build but here it goes, if I am in the wrong place please direct me. Okay the problem I am having is something I have been unable to find anywhere and my thought is it must be something that happens? I have build a DIY CNC that is about 60" Y axis x 32" X axis and it has been built from 80/20 3 x 3 and 1.5 x 3 aluminum. The machine is strong and solid. Everything runs very smooth without the motors, just by pushing the gantry back and forth and the X and Z work the same, just great. I am using the “cheap Chinese linear rails” and NEMA 34 motors on all axis including Y, A, X and Z. I am also using the DM860a stepper drivers with RM 1205 ball screws on all axis. It took about a year to build and because I am new to CNC I have been looking just about everywhere for help on this build. I have been following this site and getting most of my help online. After retiring and looking for something more than just my woodshop I fell into this project and I have a concern that after doing so much research and spent so much time and money I may have gotten in to deep. So if there is any chance of getting help this site might be my only hope. As I said the movement is very good and the axis just glide very smoothly all to way to all ends of the table. But when I connect the motors and test in Mach3 is where I have trouble. I am using windows 7 and mach3 and the axis seem to bind on the Y axis mostly but just a bit on the X axis. My Y axis is set up with 2- NEMA 34 and configured in Mach 3 as “A” slave. I have been looking everywhere for some advise on how to figure out what the problem might be and from what I can see it could be many things and as I keep trying each one. I have read that the problem might be the RM860a drivers? or some files on the windows 7 computer. If there is someplace I can look to find some advise or if someone knows what my problem might be I am all ears!! I can send photos if anyone would like to help. Thank you

Possible your Y motors are working against each other?

Disengage the motors and make a “flag” of tape on each shaft. This is to visualize the stepper movement more easily.
Now you can check the rotation of the Y-motors mentioned by Neil.

A video (cell phone, shared on youtube for instance) of the problem might be more good intel to share :slight_smile:

What make a stepper motor stall:
1 - Mechanical binding
2 - feed rate to high
3 - acceleration rate to fast
4 - loose wires

1 Like

no I don’t think they would move at all if that were the case, but thank you for asking

Thank you for your input, I have tried all the above and it seems that maybe I am just under the impression that the axis should be moving faster than they do. I can have a successful test on all 3 axis if I slow the motors down, both acceleration and velocity. I think if I set the motors at 245-250 velocity and 50 acceleration Calibrated in MM. Sounds slow right? I have tried changing some of the dip switch settings on the driver but there is really only one setting that makes the motors work right. So I was kind of hoping that maybe someone might know about some adjustments within Mach 3 that could help. I do thank you for your help and if you would like a video I can do that if you think it might help

Video would definitely help. By “bind”, I pictured stuck motors.