Problem with g code VCarve Pro 10.5

Thanks. I do use ramps sometimes and will check before running a part with them.

I don’t use Easel i create the gcode in vcarve pro and send it with the xcarve inch mode via picSender to the machine. Will this driver work for me?

@GregoryPresnell The advantage of using arcs is that you’ll have shorter gcode files. That X-carve one posted by @MarkFrench1 had arcs removed. You wont get errors, but you’ll be sending larger files (usually not a problem).
The ones I linked have been used by many and vectric points anyone using grbl with toolchanges to them. They will also work, with arcs. Picsender can handle arcs. If you’ve always used the X-carve one, is say just revert to the old post processor or use the one Mark just posted.

Ummm I’m not sure what you mean by using ARCS.

I down loaded both your and his, guess i’ll see what works

Chrome wont let me down the zip file from GitHub

Hi Folks,

I just heard back from Inventables. There is a driver on their download page called vectric-easel.pp that solves the problem as well. I copied it to the My_PostP folder and it appears as the only post-processor choice. It is on the download page under the ‘Vectric Aspire’ icon. Inventables says there is only one Vectric driver.

Easel loads the tool path just fine. I’ll need to cut a part this evening when I get home before I can say for sure that it worked.


Does anyone know if the post processor issue is in all of the 10 series on vcarve pro or just the later updates?

I understand that it’s limited to V10.5. I didn’t have any problems before the upgrade from V10.0.

Could I copy and paste the pp from 10 to 10.5 and fix the problem?

I don’t know. My understand of drivers is limited. I installed the vectric
-easel.pp driver from the Inventables download page and it writes .nc files directly for Easel. The support folks at Inventables recommended this and it seems to work. I cut a part out yesterday that came out fine.

That’s great! I’m going to use 10.0 until I get a response from vetric! Thank you for all your help!

@GregoryPresnell Your old post processor will work. Or the easel one. Or the newly posted x-carve one. Or the grbl ones I have on GitHub. Choose the one you’ll find easiest to use.

You asked,

Ummm I’m not sure what you mean by using ARCS.

Some machines can handle g-codes that basically say, for example, start here at “X0,Y0”, end over at “X5,Y5” and make a motion of an 0.125 inch radius curve. It makes your g-code much smaller if you controller understands it. (by the way, that is a very vague generalization of how arcs work, it’s not syntactically correct).

When not using arcs, which is what folks are having to do here, the g-code that’s generated is just a lot of very short lines that end up (very convincingly) looking like an arc.

Hope that helps.

1 Like

I just went through this, its this line that breaks the gcode (at least for me):


Normally the M3 command is added to end of the line below it:

would be:

I have manually changed these line and then the gcode works.

The S16000M3 command first appeared in my code after 10.5 upgrade. Like noted above guess it was added to the gcode library in the update.

Depending on the gcode sender you use ( i use UGS) they can filter out codes like T1 if they cause a problem with your job just as an additional note.

oh and the S code is spindle speed, which is what UGS was complaining about.

For a Gcode webpage:

S= Spindle Speed
The S command’s purpose is to set the spindle speed. The Spindle speed is almost always set in RPMs (revolutions per minute).
Here is an example:

  • S10000

That shouldn’t be an issue. What error did you get?

So for me, I just copied the old grbl post processor from my older v10 install files. That got things going.

I keep getting “No feed rate set” errors in UGS.
That hack worked on one file that was only drilling, any other type of cut it failed.

Yup, they left out the feedrate initially. That error would show up on your first G1 command.
The line you said (S16000M3) is standard gcode, accepted by grbl.