Problems with Easel on new PC

I just purchased an x-carve and while I am waiting for the components to arrive I have been experimenting with Easel. It does fine on my MAC but on the new laptop I bought running windows 10 I am having some problems. I experimented with the cutting board project and when I tried to search for an image from the web from image trace I can’t get pass the search box. When I select it with the cursor, the cursor just disappears and nothing typed is shown. I tried it by running both Microsoft Edge and Internet Explorer but no luck either way. I then went to my Mac and had no problem. I looked on the forum but couldn’t find anything specifically about this. I would like to be able to design on the PC since it is the going to be hooked up to the machine. Thanks in advance for any help. Have to admit, I’m not a PC guy.


i think you are supposed to be running it with google chrome.

I use my Surface Pro 4, Window 10. No problem with Chrome.

Image search? am I missing something there? I don’t think image trace is used for searching the internet for images… it’s for tracing images you already have on your system… Are you talking about searching the ICON library??

Windows 10 with Firefox here and no problems…

Hi Steve,

I am able to search for web images using Edge 16 on Windows 10, but not with IE11 on Windows 10. I’m seeing a similar issue with that combination.

That file picker popup window is a 3rd party library that we use. I’ve emailed them to see if they are aware of this issue.


Thanks @RobertCanning
I guess I missed that. I usually already have an image in hand if I’m going to use the trace option and I guess I haven’t been paying attention…

No Problem.

Thanks. Jeff. Switched to Chrome and it worked like a charm. Thanks for the prompt assistance.