Problems with job freezing

HI Everybody

I am new to this forum and fairly new to carving, although I have wasted a ton of pine sheets on trying to get my jobs cut.
Now I know this has been asked before, but I cant seem to find a solution that works for me.
I have a problem with my job that at any random time through a job it just freezes. sometimes 90% through a 3hour cut, and sometimes 3% through a 15min cut.
Spindle is running, and easel is also saying that it is still carving, when I pause and stop to bring spindle back to home position, nothing happens, I have to shut everything down and restart everything, and start from scratch.

Equipment is as follows:
Laptop running windows 7.
2.5m long usb cable.
wifi connected to laptop.
running easel through google chrome.
Arduino with g shield:
Makita spindle Makita RT0700.

Initially it was thought that the stepper drivers were faulty, and was replaced with newer and bigger ones. but this doesn’t seem to help,
Then it was thought that wiring was loose somewhere, checked everything and all seems fine, then checked for shorts, but could find anything.
replaced the usb cable, with no luck.

I honestly don’t know what it could be, I will be trying UGC sender today, just to rule out that it is not easel that is the problem, as I don’t think it is.

Any help or comments/suggestions would be much appreciated.

Also, make sure you are going through a powered USB hub.

Thanx Guys

sorry for only replying now, thanx for all the suggestions, I tried everything, but with no success, even bought a ups today to eliminate voltage spikes or drops.
But still have the freezing problem, I have no idea what the problem is. I am also at the point where i am thinking of throwing it in the trash.

I have had the exact same problems since I bought my machine last October.
I have tried all of the suggestions that were provided to me on this form with no results. (very frustrating)
While everyone on here is very knowledgeable and willing to help you, (and I appreciate all their efforts) make sure that you get in touch with Inventables.
They realize that there is a problem with some of the controllers and are working to resolve it.
They have been working with me with new software and are also sending me a new control board that has been modified.
If these changes work for me, then they will be making an engineering change to controller.

1 Like

I just re-read your post.
You don’t have the new X controller?

Well I hope you guys are able to help him out.
I too have had thoughts of trashing the machine.
When Inventables finds the root cause, I will report on here.
Maybe the “fix” might be backwards compatible?

1 Like

I assume that your new USB cable has ferrite cores/chokes on it?

Hi RobertCanning

Spindle is still on and windows is still working, it is almost as if the connection between the computer and the controller is lost.
As if the controller missed a step and forget what to do.