Quiet Cut Spindle + PWM

Hi guys! Can you help to understand me how the PWM works?

I connected my Quiet Cut Spindle with the Spindle Speed Controller as described here:

So, when i trying to start the Spindle - it starts spinning, but only 2 seconds. Looks like spindle gets very short impulse to turn on and to turn off immediately.

I tested the PWM signal with multimeter, i get 5V during all turning on period on Controller’s PWM input terminals. Nevertheless spindle stops when i still get 5V on Controller’s PWM input terminals.

What i forget to do?
Thanks!

Thank you @PhilJohnson, but it’s not the PWM, your Arduino just send “turn on” signal from 12 pin to the power supply extend module. I use 11 PWM pin. You can see it here, if interested:

When i tried to send m3s12500 by http://chilipeppr.com/grbl effect was the same as by setup page of easel http://easel.inventables.com/setup. The spindle starts to spin and stops after 2 seconds.

But m3s8000 causes the spindle to spin constantly :slight_smile:

Strange, looks like easel produce wrong G-code, or something wrong with my spindle or controller?

1 Like

You have to be careful interpreting a voltage meter reading of a PWM signal.

Try this test. Disconnect the plug that has the PWM signal in it from the gShield to isolate the gShield/Arduino from your speed controller.

Send the Arduino an M3 S0 (0 for 0 rpm) command. This should force the PWM pin (D11) to a logic zero state. Measure the voltage on the PWM pin. If it’s 5 volts then replace your Arduino.

1 Like

Thank you guys for your help. I will use just the relay. As described here:

It works as described. Looks like the Arduino works well. Not sure what’s wrong with PWM…

Most likely a failed speed controller. They tend to be problematic.

I had the same issue with mine.
It was due to the rpm speed in easle being too high.
I find that if the spindle is cold I can run at 9500 - 10,000 rpm, if it’s warm then 9250 is about as far as it will go.

Basically with easle defaults mine will start, run for a moment then the spindle will stop. Simply lowering the rpm, fixes this issue.
Each time I start a new project I need to check the RPM in easle

Sounds to me like the PSU powering the spindle has overcurrent protection… The inrush current for the quietcut, and other similar DC spindles is quite significant, there’s an easy way to test this out. Simply turn the spindle on using M3 S100 if the spindle doesn’t spin, trie S1000 if it does spin, and doesn’t cut off, up that to 2000, and so on until you reach full speed. If you can maintain full speed by slowly ramping up the speed with this method, then the PWM controller is fine, and more than likely, it’s the PSU for the spindle is the culprit.

I ran into this issue, and as a result, rather than throwing more $$ at the machine, i simply created a macro to insert this ramping up of speed into my g-code editor, and place it before any M3 commands… The down side, is on drilling operations, where the spindle starts, and stops frequently, you may need to manually edit.

Another work around, is to set the MINIMUM_SPINDLE_PWM setting in grbl.

It’s also advisable to actually measure the spindle RPM’s at different settings, and adjust the SPINDLE_MAX_RPM and SPINDLE_MIN_RPM settings in grbl accordingly so that you’re actually getting the RPM’s requested.