Ready to carve, nothing happens

I’m getting pretty frustrated with this Xcarve, as it seems every other time I run it something happens. As much as you pay for it, should it be this hard?

Todays dilemma is this:

  1. I finish my design, and am ready to carve, the “carve” button is green, so i know my xcontroller is connected, I hit carve.
  2. at the next screen i try to home it, nothing happens, i try to skip it, nothing happens.
  3. If I do get past the home screen, it locks up when i z probe, if I can get that to recognize that its plugged in, clip attached, and making contact.
  4. the bigger problem is, if I get to actually carve after setting the X/Y it will carve for 10 minutes and then stop right in the middle.

What am i doing wrong? I’ve followed some of these threads and its way over my head, I know the computer and x controller are synced but the xcontroller doesn’t communicate with the motors.

I’m spending like 2-3 hours a day troubleshooting this thing. at this point I can’t even get through the pre carve menus. I’m so over it as it took 2 months to get and I’ve only made 8 carves, it seems every day something new messes up.

what I’ve tried:
reinstalled the drivers
Ive replaced the USB cord 3 times
I’ve tried hooking up the usb straight to the board input inside the xcontroller, nothing.
Ive separated the dewalt 611 cord from the cable tray
my machine and dust collector are grounded
I’ve checked all connections they are good


How old is your computer that you’re using?
Have you tried calling Tech Support?

For the connection issues, at least try a powered (externally) USB hub.
Have you tried a different browser?
Have you tried a different sender program like UGS?

Hi @JohannPedolzky - If you haven’t already, make sure to reach out to our Customer Success team (you can call or email here.)