Ready to just throw this darn thing in the TRASH

If you can post your machine settings here, we may be able to help troubleshoot the Z axis issue and make recommendations for other settings. If you can give us a list of the other problems you’re having, we may be able to help you fix them.

As for the G-code, there is a beta app that will allow you to import G-code into Easel. You can go to this forum and ask to be let into the trial group, and see if your G-code works: [NOW LIVE] [new feature] G-code sending through easel

Inkscape is a free program that will let you open your cad files and save as a .svg. Adobe Illustrator will do so as well.

You don’t have to use Easel, and it necessarily limits you to its capabilities.

Information on using the ShapeOko 2, the X-Carve’s predecessor may help:

http://www.shapeoko.com/wiki/index.php/Workflow

http://www.shapeoko.com/wiki/index.php/Software

This might just be me, beta user, but I have a import button which allows me to do a photo import. Easel then tries to trace the lines.

Thank you all so much for your help. I will try this tomorrow and see what happens. I feel so much better now and hope this works out.

stick with it. You’ll get it worked out and will love it

I thought that the import button was only for V-carve and the programs by Aspire. I have not tried it for other gcode.

I have the x-carve 1000mm x 1000mm with dewalt 611 router on it. I ran the machine setup, put spindle on manual, told it to home using the buttons in easel. It seems to touch the micro switches just fine to home it self at the lower left corner but all the way at the top of Z. Then when I tell it to try a test carve in Easel it raises the x axes to get away from any materiel and that just raises it into the micro switch more bending the arm of the switch.
Again thanks for your help

just manually home it.

What’s your safety height set at? I only use Easel, but it says mine is set at .150". If your machine has a ridiculously large safety height, or the g-code is converting mm to inches and trying to lift 3 inches instead of 3mm (example only), that could be one issue.

Have you calibrated your Z axis? I don’t know how to do it in other programs, but I did a calibration video that shows how to do it in Easel (X-Carve Maintenance/Troubleshooting Videos - Add Your Own!), Z would be the same basic way, just use a way to measure height accurately and adjust the steps/mm or steps/in accordingly.

yeah I am curious why are you trying to home the machine each time? are you only cutting one thing over and over? because if your not you will be changing your homing position all of the time

This may be a silly question but after you have homed the machine do you lower the z-axis(AKA lowering the bit down) or are you just starting the cut?

The homing switches are just there to give you a starting point. You still have to move the bit after this to where you want it on the material. This means lowering the Bit down to the surface of the material to the point where it touches the material. If your skipping this step then the top of your z axis will be 0. And any + value sent to the gshield will be higher than the z axis switch.

Well Geoff you hit the nail on the head. I was not lowering it down and placing it where it needed to be. I did not know how this was done at first. I was just following the menu thinking it was already programmed into easel since I had to give it a materiel thickness. The micro switch should stop that axis when the switch is activated and not allow it to continue.
I spent 5-6 more hours last night just going through you tube and things in this forum finally found out about universal gcode sender so I will try that and see what happens.

JDM: I am really sorry but when someone is at the end of their rope just telling them to just home it does no good. if you can not find the answer yourself and no one has told you what programs to use or how to do it. Since Mach3 or 4 can not be used I was at a loss as to what program to use to enter code to move the thing. Using the Arduino is totally different then using break out boards and the “standard programs”

OntheEdge: I was just trying anything to move the axis and one thing was to just reset the machine so that is why it hit the top axis twice.

THANK YOU EVERYONE for helping me out and hope now I can get things going. I know it’s a lot of trial and error. I am still excited about the machine and recommended it to a friend just yesterday.

1 Like

One thing you probably want to consider is to set soft limits on, this will take care of the bent limit switches by throwing an alarm when the controller receives a command that would move any axis outside its allowed travel (you’ll have to reload Easel if this happens because it can’t recover). Go into the advanced section of the machine inspector in easel and set $20=1. This helped me when I was having the same problem.

This thread might help:

Hey, glad to hear you’re getting some success out of it! NOTHING is quite as aggravating as knowing you’re not knowing something, but not knowing what it IS that you’re not knowing! It’s a continual loop of rage. lol

Thanks Again.!!

Yes, sorry. From reading, I did not understand everything you were describing. When you manually home the machine, you put the tip of the bit right to the top of your work piece. I grab the little wheel on the z and manually rotate it until it just touches the material. That will be the home position. The limit switch on the z does not have any bearing on the home position.

On a semi-related note, you seem to have some familiarity with cad programs, so Autodesk Fusion 360 might be of interest to you. There is a fee 30 day download, and hobbyists can register it for free (no time limit) if you are using it as a hobby or in a business making less than $100,000 a year.

Fusion 360 is both cad and cam so you can design a part on there and use that to create the gcode directly. My xcarve (but I finally ordered it!) has not arrived yet, so I have not personally used it, but youtube videos I have seen show them exporting gcode in grbl format and using a gcode sender (not sure which one of the top of my head). Fusion 360 does have a learning curve, like everything, but there are a fair amount of good youtube videos for it.

Hope that helps, and apologies if it does not. Best of luck!

1 Like

Hey friend take it from someone with a bad temper it will get better just use lock tight and get some heat shrink tape when i got mine i was ready to sell i was in contact with inventables everyday i finally got everything rite and im runnin so friend hang in there it gets sooo much better i am makin stuff that used to ■■■■ me off it is easy once you get thru the learnin curves oh get yourself a sheet of MDF and go to town when something happens its just a learning piece of wood well friend i have walked your shoes you can get in touch with me if you have any ?s

Just so everyone here knows. I did get it running after a lot of trial and errors and talking to Inventables a couple of times. I started using ugs at first to get things moving then I switched to chili Peppr which is a really nice program. Yes the spelling is correct. Thank you every one for all your help keeping my head on my shoulders and plugging along till it fell into place. There was some bad code in my arduino that Inventables found and corrected for me.What great support from them and all of you. I can see inventables going places with such great machines and support. Thanks again.

5 Likes