Really getting tired of glitches in UGS and all the hassle it takes to to get a good carve

I assume the best way to reliably send G-code is to upgrade to a Gecko 540 and Mach4.

Could someone point me in the direction of an installation thread?

I can’t help with Mach4 but I am running a Gecko G540 and Linuxcnc. G-code generated by CamBam or Fustion360.
I haven’t tried easel as yet.

What all is involved in installing the Gecko 540? Is it a fairly straight forward install?

I haven’t used it, but try this http://www.picengrave.com/PicSender.htm . There’s a demo, and the full version is only $14.95, so not much to loose

2 Likes

@JamesMccarty i cant belive no one suggested chillipepr . I never had issues with either easel or ugs, but chillipepr works very well.

http://chilipeppr.com/grbl

EDIT: its free too

What version of UGS are you running?

I’ve had a ton of issues with UGS hanging right after I upgrade Java. When I download the latest nightly it usually fixes the problem. Just had to do it last week. Nothing sucks more than a wasted job and materials it FUBARs.

0.02. YMMV.

-Tom

The Gecko install is very straight forward. All it needs is a power supply (48V max) and a connection to the parallel port on your computer.
If you don’t have a parallel port then you’ll have to use something like a Smoothstepper.

1 Like

Ill try Chilipeppr. next

The most stable I have found is the 1.08 UGS but even then, its a coin flip if it will work.

This is the main issue I have,

Ill set the work up, zero the program and load a file.
Then I click send.

Sometimes it works right, and sometimes it cuts the work on a 1/50th scale (I really don’t know the true scale, but a 10" tall piece of work ends up cutting at less than an inch) Its like all the axis are moving correct direction, just extremely small amounts.

I’ll have to stop, put a new piece of word in or move the x axis over and reset zero (if I have room)
this might happen 2-3 times before it finally cuts right.

Sounds like your post processor is not inserting the gcode command to use inches so the Grbl is assuming the code is in mm.

That is exactly what it sounds like.

You should be able to open your gcode file with a text editor and verify that one of the first commands is “G20” which sets the units to inches

G21 will set the units to mm.

If there is not a G20 or G21 then Grbl will just use whatever units it last received a command for, so if you happened to jog 1 mm to the left then ran gocde with no units specified it would use mm.

Here is an example of Gcode created using the Inches Post processor in Vcarve (comment were added by me)

T1M6 – Select tool 1 (not necessary but it does not hurt anything
G17 – select x/y plane
G20 – Set inches as units
G0 Z0.8000 – all the rest of the commands are to move the spindle
G0 X0.0000 Y0.0000 S12000 M3
G0 X0.0220 Y0.9158 Z0.2000
G1 Z-0.1000 F20.0

i had nothing but trouble with UGS 1.08

if you havent yet try the nightly build v 2.0 its worked flawless for me

1 Like

Same with me, I have not had any trouble with version 2

Is that the one with the new UI? Or does the nightly support v2 without the new UI?

I use the nightly with the old UI.

Thanks AllenMassey. You were spot on. That fixed the issue all together.

I’ll try out the nightly build again. Also want to try chillipeppr

What does Mach4 offer if anything that is different/ better?

Mach 4 has tons of features and has been the industry standard for CNC controllers for many years. But the Arduino/Grbl is not compatible with Mach 4 so it will require a pretty major change in your electronics to use it.

A lot of people on this forum use and like Chillipepper, I tried it and decided it was a hot mess. In my opinion the UI is very cluttered and setup is difficult compared to UGS. Plus I was constantly having connection issues with Chillipepper.

I am sure 50 people will say they never had a moments trouble with Chillipepper and it would often bring them a hot beverage when they were tired. But that was not my experience.

So I use UGS 2.0 and it has been a dependable work horse for me.

1 Like

I have found that UGS defaults to metric (assuming you are using inches). I have to switch from inches to metric then back, rehome and it seems to work ok.
SO far I like it better than Easel because Easel has a real issue with where the work zero is. It wants to go somewhere off the machine.
Easel is not bad but very limited.
I have found GWizard Editor for creating the G code because it shows you the path the tool takes for eack move , points out errors and generates a clean G code. UGS takes it from there.
Try it, best thing out there.

I agree, Chillipeppr is very convoluted, hard to read and get connected. So far all it has done is crash my machine.
However, that said he did manage to get a Contour Express Shuttle to work as a jog wheel.