Inventables Community Forum

[Reference thread] Alternate method for .hex upload

Update 12/29/2015

It appears that this doesn’t work on Windows 10. I don’t have Windows 10 so I can’t try it, but another forum member tried it and it didn’t work for him.

Updated 12/12/2015

Revised method for uploading a .hex file to the Arduino. This is an alternate method for uploading if you have difficulties with Xloader. This version prompts for the COM port and filename.

**** Readme file 12/12/2015 ****

To use this .zip file to load a hex file into your Arduino you first need to copy your .hex file to the same directory where you unzipped this file.

Double click the AVRDUDE_Upload.bat file and a command prompt window will appear.

The first thing the command prompt window will ask for is the port that the Arudino is attached to. For example, COM1. Enter the port name on your system where the Arduino is attached.

Next the batch file executing will ask for the filename of the .hex file you want to upload. Enter the file name of the .hex file you copied into the location where you unzipped the .zip file.

Now the batch file will upload your .hex file to the Arduino.

Once finished the batch file will pause to let you look at the upload comments. Press the space bar to allow the batch file to terminate once you have examined the upload comments.

Be sure to keep all of these files in the same directory and execute the batch file from the directory where you unzipped the files.

The grblUpload.hex file included is grbl version 0.9j from the Inventables fork.

AVRDUDE_Upload.zip (251.9 KB)

1 Like

This is good stuff, Larry! I’m among the successful Xloader users, but I always like to have more than one way to perform a task too. Thanks! :slight_smile:

Hi noob question for you how do you change the comm port

There is a command line inside the .bat file where you make the changes.

Here is the command:
avrdude -C avrdude.conf -v -p atmega328p -c arduino -P COM19 -b 115200 -D -U flash:w:grblUpload.hex:i

On the machine that I tested this on the COM port hooked to the Arduino was COM19. So, on your system you would determine which COM port the Arduino is attached to and change COM19 in the command to whatever your port is.

grblUpload.hex is the name of the .hex file that will be loaded by this command. If you want to load a different .hex file you would change this name in the .bat file before you run it.

1 Like

Sorry to keep bugging you but ive just done this and went onto easel and run the machine setup then the test carve and the little robot fella is taking up all of my work space any ideas if it is part of the same problem.
cheers martin

I’m not sure what problem you are talking about. I don’t use Easel, so I can’t help with that. It might help if you could describe the problem you are having and maybe upload a picture if that would help. Might want to start a new thread if you think it is an Easel problem.

Updated this with a version that prompts for the COM port and .hex filename.

Hi thanks for your help. It’s all up and running again the hex file I had downloaded was a bit wobbly so once I’d changed a few of the grbl settings it’s now running better than it was before I managed to blow the original board.
Cheers Martin

@LarryM You come to the rescue again!

I purchased and received a couple of Arduino clones that were suggested here on another thread. They are the Elegoo Uno R3. The first thing I did is to see if they are using an FTDI clone and it was not so all good to go for communications. So I then used trusty Xloader to upload GRBL 1.1f hex and nothing! Uploading message on the software but the TX/RX leds were not blinking. Tried to copy the current avrdude.exe and…nothing! Sketches uploaded without a hitch with Arduino IDE 1.8.1 sooooo whats up? No real info on Xloader and Win10 but your info comes up on a search and using your batch file, Bob is your Uncle! GRBL 1.1f loads and the Arduino works as advertised.

A big thanks for all your help!

Oh yea, here is a link to the Arduino Uno boards if you are curious.

2 Likes