Reseated G Shield to Arduino and only Z Limit switch works

I originally had none of the limit switches working so I took the board out of the enclosure and married them together. When I tried than to align the switches I got rather excited when the machine recognized the Z limit switch and the gantry started heading to the Y limit! I thought my problems where going to be solved and I would soon be carving! Unfortunately when the gantry reached the Y Limit it did not activate the switch and kept trying to crush the switch. I am completely unfamiliar with this GRBL code speak and another forum member suggested I run some type of program to check my GRBL settings… way over my head… where do I start? I am running Easel on a MacBook.
Thank you

Check this thread to learn how to talk to Grbl. Once that’s done, enter the command $$ and it will output the Grbl parameters. Post them here.

Here’s a tutorial for installing the Arduino IDE.

Do not load the blink program it will erase Grbl.

Larry thanks for all the help. My machine is running! I found a few bad solder joints and now the limit switches are working properly. I found it impossible to seat the G Shield and Arduino together without taking it out of housing, mating than placing back in housing without screwing down. Thanks again!