[RESOLVED] Arduino beginner having problems connecting Mac to newly assembled Xcarve

I just assembled my xcarve 1000mm and cannot get my mac to recognize the xcarve during Easel setup. I am running El Capitan on a 64bit Mac. I have tried in Safari and chrome, and on a W8.1 laptop, but cannot get the xcarve to be recognized by Easel local.

I have been reading the posts and it seems that it may be some Arduino related issue, but I have NO idea what I am doing with Arduino boards. I have downloaded the Arduino IDE and hexloader to my Mac, but could really use some beginner friendly instructions to try to fix my problem if the Arduino is the problem.

I’m not Mac user, we do have friends can answer your question shortly. I only want to give you a warning. Do not attempt to load any Hex files to arduino unless you are certain about the pre-loaded software is bad. I don’t think you have Arduino problem. Unrecognized connection mostly caused by GShield and Arduino connection. Go ahead and remove your GShield up, try reconnecting again. If mac can read connection without GShield connected, means you’re missing pin connecting GShield to Arduino. Watch pins and go slowly.

@AlanDavis is right, it is more likely a physical problem rather than an issue with software on either your Mac or Arduino. Double check the connection between your gShield and Arduino and even test without the gShield connected. Start with that and if you still have issues, report back here.

Thanks guys. I will try this evening and update. I thought the gshield was seated correctly though as I got the blue light and all three greens when I plugged the usb into my MacBook, but I am eager to see what happens when I unseat it.

ok, just disconnected the gshield and tried configuration with easel, still will not recognize the xcarve.

I am running the following:

2012 macbook pro w/retina display.
2.9Ghz i7 with 8gb DDR3 RAM.
OSX 10.11 beta - El Capitan
Google Chrome Version 44.0.2403.157 (64-bit)

I have the xcarve 1000mm with the arduino uno board (SMD edition) and gShield v5b.

Power unit functions and turns on, and distributes power to the boards. Still no luck. officially open to suggestions.

If it’s not your electronics, next to blame is your PC connection. You may want to focus on your USB ports. If it is Windows PC, I would suggest external Powered USB hub. Because most of us had connectivity problems, one cheap powered USB port solved it. Even I have very good desktop, it was the solution. Seems like you’re not feeding Arduino with enough power. As you know Arduino gets power from PC USB port. But I don’t know if you have same port on your Mac.

From your original post you have tried on a Win machine and a Mac?

Are you using the USB cable that came with the X-Carve?

Edit: also, the one thing that gives me a little pause is that you are running EL Capitan… it is beta and could be throwing a wrench into the whole thing. Do you have access to a machine running Yosemite and Safari?

I’m with sketch, beta software in the mix may not help.

Yes, I have tried both, but not a Mac running Yosemite. The pic recognized a sub device was plugged in, but got hung up when entering the COM port. So I will probably stick to the Mac for now.

Ordered a powered USB 3.0 hub. What is the power required to run the arduino and shield? Shouldn’t the USB 3.0 port on the Mac handle it?

I don’t have my XCarve yet, but as a Mac user, I am definitely watching this thread.

Make sure you are using the supplied USB cord. I have had issues with one device where certain cords didn’t work with it. And try various USB ports on your computer too - I had another device that was picky about which USB port it was plugged into.

Yep the built in USB on all modern Macs can handle the power requirements of the Arduino. The only reason to purchase a powered hub would be if you had a really long USB cord and wanted a range extension.

If the Win machine had issues picking the port for the X-Carve it seems like the issue is not Mac specific and is still more likely with the Arduino or something similar.

If you are absolutely sure that the USB cable is good, and the gShield is well seated into the Arduino then before dragging this out or making any purchases, I would definitely reach out to Inventables support. Send them an email or better yet, give them a call:

The forums are pretty great for problem solving, but Inventables support and customer care are awesome. Really, they are the next step in this issue before anything else.

Looks like El Capitan is the problem. Tried it with powered USB hub on El Capitan and no luck. Tried it on a 2013 macbook pro retina display sans powered hub, and it connected right away. Was able to calibrate the machine, adjust the motors and get everything running for a test carve…until I broke the bit. But that seemed to be a wobble issue in the z-axis mount.

Thanks AlanDavis and Sketch42! you guys are awesome.


Glad we could help.

I have a feeling that El Capitan will work with the Arduino soon.

@GeoffMccleary do you mind if we mark this as [Resolved] ?