Inventables Community Forum

(Resolved) Cannot get past homing in setup. X axis movement bounces off homing switch

(resolved) New to CNC. Completing setup of X Carve 1000 x 1000. All homing switches properly give green light in advanced settings when pressed. Machine properly moves and stops at z and y homing switches. But seems to continuously “bounce off” switch on x axis. Machine does not continue into the switch, just engages/disengages switch repeatedly. Any recommendations?

Weird. Can you get a video?

Check for any loose wiring

1 Like

Ok, not what I pictured. Your X switch isn’t being pressed or the signal isn’t being read by the controller.
As @SamGironda said, check the wiring for the switch and check that the machine actually makes contact with the switch.
That’s what it looks like when the machine is trying to continue moving but can’t. The motor is skipping steps.

I’ve triple checked the wiring and it is secure. As noted, when in advanced settings, if I depress the switch, I get a green signal in Easel. I’ve moved the block pin further out, and it always stops at the pin, it just seems to rebound continuously.

I am going to say that the travel is not getting to the point of activating the switch. The pulley is slipping on the belt teeth causing the bouncing.

This seems likely based on what i’m seeing (over and over). Any recommendations on a possible solution? I’ve tried loosening the belt some. It still “twangs”, just not quite as tight.

Move the switch so it is reached.

The belts won’t slip unless they’re extremely loose, it’s the motor.

Anyway, like @MarkA.Bachman and I said, check that the carriage is physically contacting the switch.

Contacting the switch is not enough it has to move the switch enough to activate it.

1 Like

Bend the arm on the switch a little, see if that helps.
If the switch is triggered the axis should pull back 1mm (defined in GRBL parameter $27) then feed into the switch for the the 2nd and final time.

solved. the frame/plate for the z axis was hitting the aluminum collar on the stop bolt before the switch could fully engage. tried moving the homing switch a little (with no success), and added a pad to the contact bolt extending it’s reach. this is likely a short term solution, but at least now I know what the problem is/was. problem found

3 Likes

Where do you find the settings to test the actual Homing switches like you stated?

hi
i have the same problem cannot pass homing Z end stop not actif
can get them working i test the signal is not on help some one thank you

  • If the Z-stepper dont stop and Z-switch is not pressed, but Z-switch is working when you press i manually => Z-carriage do not reach Z-switch
  • If Z-switch is pressed only once by the carriage but stops => the pull-off distance for 2nd press is insufficient. Increase $27=5 and retry.

hi
thank you for your help machine is working thank you