[Resolved] Carve button not turning green on additional jobs

I’m using a Windows 7 laptop and Easel in Chrome. When I open a job, I can make one piece just fine, but when I try to make a second piece using the same job, the Carve button won’t turn green. When I finish a piece, I turn off the spindle and unplug the USB cable, then I move the spindle out of the way and change out the material and set up for the next piece. I usually leave the power supply on. When I plug the USB in to cut the next piece, the Carve button stays blue. If I click it anyway, it prompts me for the com port but it’s already entered. If I reboot the laptop, the same situation happens - first piece works but not the next one. What is the recommended procedure between pieces so that the Carve button will turn green every time?

Restarting Chrome does not help and I don’t see any Task Manager process that is hanging up that I can kill to make the button go green for the next piece. Turning off the power supply between pieces doesn’t help either. Thanks, Steve…

Are you keeping multiple tabs/windows of Easel open?

Hi Justin - No, I always close everything except the one job I’m working on. Closing Chrome and opening the job again doesn’t help either. Only rebooting seems to ‘reset’ it so the button will turn green again.

Why do you unplug the USB cable between jobs?

To disengage the motors so that I can move the spindle out of the way to change material. If I don’t unplug the USB, I can’t move the spindle. I position the spindle at 0,0,0 manually for the next piece.

Hi Steve,

What happens if you don’t unplug the USB between jobs?

@SteveCarmichael this isn’t the best solution but instead of unplugging the USB you can click Carve again and use the arrows to move the spindle out of the way.

@paulkaplan recently updated the local sender. The current version is 0.2.2 and it does automatic port detection on Windows. You can see what version of the local sender you are running. If it is an earlier one you can delete it and upgrade to this one.

I can also share this situation with our engineering team when they get back from vacation.

@SteveCarmichael I’m being told we’ve been having this problem with vista/windows 7 users. Engineering is looking into it but the current fix is uninstalling Easel Local and reinstalling version 0.2.2. If that link didn’t work for you then call in 312-775-7009 and ask for John Hayes. He can remote into his computer and take care of it.

@Zach_Kaplan Thank you for the quick reply Zach! I will try clicking the Carve button without unplugging the usb and control the machine with the arrows tonight. I may try reinstallling 0.2.2 too. Thanks!!!

You can use the arrow keys to move the spindle around while you’re in the Carve screen. Shift-up and shift-down control the Z axis. Just make sure you click the move direction with the mouse, since up/down in the increment screen causes it to change to some wacky number.

Also, double-check your move increments before you mvoe, especially the Z axis. I may have accidentally tried to drop the Z axis by 1 inch instead of .1 inch once or twice. Or more… :smile:

@RobertA_Rieke Thanks! Yeah, I don’t trust myself with those jog buttons very much. That should work as long as I get the green carve button after carving the first piece. I suppose I need to measure how far the machine leaves the bit above the surface when it goes back to 0,0 after a carve. I could jog it out of the way in one direction making sure it will not hit clamps, then jog it back the same amount, then lower it to the surface for the next run, as long as I put the new piece in the same spot.

I believe it goes to the safety height in the Advanced menu. I think mine is .150", the default.

I also found out that as long as you don’t have to change the 0,0 location and as long as you only move the spindle by the controls, you don’t have to return it back to the 0,0. You can tell it to start carving at the previous home and it’ll go straight to the first cut area. Just make sure there’s not a clamp or something between the spindle and the cut area, otherwise you’ll take out your bit.

It works! Thanks for your help guys! I was able to knock out my remaining gifts in no time. Didn’t have to reboot once. Here are some notes:

  • The Carve button stayed green as long as I did not unplug the USB.
  • I was able to drive the spindle out of the way for material changes then put it back at zero. Just have to be mindful of clamps and the distance interval.
  • After a job, the spindle is set to the safety height, so that’s good to know.
  • I uninstalled Easel Local 0.2.1 and installed the 0.2.2 that Zach gave me. (The exe that downloaded was named 0.2.2 even though the link above says 0.2.3.) I attempted to unplug the USB and plug it back in 3 times and got the green Carve button every time, so I think that fixed it.

I’d like to say that this forum is AWESOME! I think this is the first troubleshooting post I’ve made, but I read the forum everyday to keep up with the latest discussions. Thanks for the help!!! Steve…

1 Like

Awesome! It takes a village @SteveCarmichael. Also thanks for pointing out the typo on version 0.2.3 vs 0.2.2. I updated it to accurately reflect 0.2.2.

In version 0.2.3 we are doing the auto-detection of the ports and that version is having problems on Vista and Windows 7.