[RESOLVED] Cuts missing / omitted from preview

Using Easel, 1m X-Carve.

I Imported a DXF file (not my design) and and it is correctly reproduced in the design panel for Easel. In the preview panel, it is missing a significant cut (attached image)

I’ve had a similar problem importing other DXFs but I could usually work around it. In this case, the curve missing is mathematically specified, so I’m unable to recreate it exactly. Will the cut still happen even if it doesn’t preview? Is there a way to fix this?

I’ve tried to copy/paste the cut line. The duplicates also do not appear in preview. I also tried chrome, Firefox, and safari and have the same issue in each browser.

Any help appreciated! Thanks!


It was a problem with the file. The curve was not a line, but a loop, and I think it was confusing Easel. When I went into the “Edit Endpoints” menu, I started deleting endpoints beginning on the far right side. I noticed that many of them were double stacked, and the endpoint on top connected to the loop end

After deleting all of the double stacked end points, I used the extract subpath add-on to remove the horizontal crossbar.

Everything working like it’s supposed to now.

Missing lines in the preview usually means the lines are to narrow to cut with the chosen bit size. Change your bit to a smaller one and they’ll show up.