[Resolved] -Jogging X & Y goes 3x the distance whether mm or inches on new X-Carve

Yes, you can send Grbl and G-code commands to the UNO without the gShield. See above.

You can use a terminal emulator, but it should be much easier (and more beneficial) to just install UGS and get it talking to the Arduino. UGS already has all the functionality you will need to send gcode and configuration commands. Plus it will allow you to test the movement of the machine with “Jog” controls. Eventually you will need a real gcode sender so why not go ahead and get that working.

Let make it simple. HEX file for Arduino Firmware. GShield receives command from Arduino, G-Code is the machine language tells Arduino What to do. Arduino takes those codes, convers to proper voltages and sends GShield to control Drivers. I hop this clears a little.

For start ups I generally recommend a terminal program to eliminate as many chances for failure as possible.

I know UGS is good (I use it), but it does have some problems from time to time.

i may have mentioned i have both HyperTerminal 7 & Putty downloaded into my DropBox - i’ll pull them off tonight & get them tested out.
I DID find a link to UGC and downloaded the zip & un-zipped it.
the readme.md file says to run, simply unzip the .zip file and double-click on the .jar file. why in the world couldn’t they just say WHAT .JAR file it was. this has happened to me more often than i care to mention.
so… do i have the wrong zip file, or is there a certain .jar file i should be a clickin’ on. (a search on *.jar came up with 62 files in the folder. meh)

Suggestion, Copy zip file into single folder, right mouse click on it and say extract here. Besides, you’re not going to start Jar file, must be start.bat file you have to double click. Not to mention , UGS is Java based program, make sure your Java is up to date.

Double click the UniversalGcodeSender.jar file in the directory where you extracted the files.

This works for me on Windows 7.

Here is explanation from GitHub ;

Universal GcodeSender is a Java based GRBL compatible cross platform G-Code sender. Use this program to run a GRBL controlled CNC machine.

To run simply unzip the .zip file and double click the .jar file. On some platforms you will need to run an included start script.

Note for MAC users: For version 1.0.8 and earlier you may need to create a “/var/lock” directory on OSX to fix a bug in the serial library. To do this open the Terminal application and run the following two commands:
sudo mkdir /var/lock
sudo chmod 777 /var/lock

Alan, that’s a great overview. I think people should send those things out more often.
MIKE, (and everyone) last night i loaded Hyperlink on my notebook. i tried to get into a couple of my arduino boards that i thought i had set up with the grblUpload, but couldn’t get in. then i installed on a 3rd UNO and when i used hyperlink, i was able to look at the parms that were setup ($$) and also revise them. as you mentioned, many of them were way off from your example. i then change most all of them to be in line with your example, rev’d up Easel and i could tell right when the connection was made that the Jogs were much shorter than they had been. (the Subject of this Topic).
I went through all the steps and everything seems to work “exactly as expected” except for my limit (zero) switches. but THAT is in a different Topic, I went ahead with out using them.
ran through a mock (no bit in the spindle) carve and it seemed to work perfectly. <-- really wonderful to watch that thing move around so smoothly for the 1st time!
I then taped a marker to the spindle & did another mock carve & it worked seamlessly!
thanks to everyone for your help. I like reading through most of the troubleshooting topics, there’s much to gain. please, keep up the great work that’s being done in this forum and I, too, will try and be a helping force as my experience grows.

I’m fine with marking this topic [Solved].
do i do that or does a moderator do that?

Russ from Coral Springs, Fl.


Glad to hear you got it worked out! I’ve marked the topic as resolved, thanks for sharing what you went through to get the problem fixed :smiley:

1 Like

Russ, I think I can save you some time when you start working on this.