[Resolved] Trying to get x.carve to respond

Im trying to use Easel software with X-carve. I run app and it wants usb plugged in and
unit on which it is but doesn’t go past that menu.
Not sure if drivers are installed all ok. Is there a way to command the X-carve to move
so I know it is responding to software?
I have power supply on and spindle in off position toggle switch on supply in midddle.
What is next?

Have you installed the Arduino software yet? That should install the proper drivers.

To just check for communication, you can use the serial monitor in the Arduino IDE to send G-Code commands. Really you can use any sort of terminal software that will connect to a COM port. Universal G-Code Sender is a third option that seems to work well, and has a basic Graphical Interface that you can use for jogging the axes.

I guess not so will do that and see if I can get it to respond:)

All of the G-Code runs on the Arduino itself, so you can still access the commands even without anything else attached. The 5v pins on the arduino can be toggled without load and won’t be harmed at all. I just wouldn’t attach a load to an already powered pin. Even with the stepper drivers, you are mostly just applying gate voltage for the MOSFETS which is pretty low.

If you’re concerned, just leave the 24v supply turned off and the shield unpowered. Nothing will move, but you’ll still be able to see the back and forth communication in the serial monitor.

EDIT- If everything is powered and attached, you can use G-Code commands to move the motors through the Arduino Serial Monitor, or other terminal software.

Trying to setup machine type which X-Carve 1000 and I just get to the Connecting to X-Carve…
Plug in your USB cable and turn on the machine and then it goes no further. All I can do is hit cancel.
I have easel drivers installed.

This system was all put together so didn’t run through that part but have installed drivers
and the Arduino software but looks like I will have to go throught their section of setup and see
if anything turns up.

Its a new computer I bought for it so this computer wasn’t hooked to it.

Yep will do that and see what happens. Where are those instruction? Im looking for them???

Got it respond now and the 2.2 driver works, the 2.6 would hang up. Now it goes on to the testing
movement mode with the arrows. All works fine.
I will have to run run a test carve like it sets you up for now.

Thanks for info to try the 2.2 driver.

Yes its working all ok. Did the test carve all ok too. Thanks for the 2.2 info, that made the difference.
Not sure why the 2.6 doesn’t work and didn’t try any other versions. I will stick with the 2.2 for now.

1 Like

What does your Arduino look like? Is the USB connector on the Arduino large and square or is it small and flat?

In 0.2.3 they introduced an autodetection feature for the X-Carve/Arduino. This works a lot of times for a lot of situations, but does not detect the drivers in all situations. Going back to 0.2.2 allows you to manually select the COM port. As far as I can tell, that makes the difference. Going back to a previous version is a workaround, but not a real solution. Hopefully they can get it worked out soon.

Large and square usb.

I reviewed this situation with our software engineering team. They mentioned a potential fix the issue of having to downgrade is we can build in a fallback option you are in the situation where automatic port finding doesn’t work.

If you are in the situation where only v0.2.2 works can you please post back your OS and version of that OS?

1 Like

Thanks for looking at this.

For me it was twice

Windows Vista Home using chrome browser
Genuine arduino

Windows 10 clean install and update the day of attempt
New version of Chrome downloaded same day
Clone Arduino with CH340 chip (micro USB).

The second computer worked on the latest version of Easel when using another Arduino clone with the standard UART (USB B).

The clone used on windows 10 (second computer) is recognized, and works with UGS and older versions of Easel. Not sure it matters, but it does not appear in the list of COM ports as an Arduino like the ones that work for me with Easel. It appears as “USB-SERIAL CH340”

Here is a screen grab of my com ports with both connected.

I have a Windows 7 OS 64bit on the machine for X-Carve

If you are having connection problems, there is a tool in Easel that can help us gather information about what the problem is.

  1. Click the “Carve” button
  2. You should get a pop-up that says “We can’t find your machine automatically”
  3. Click “Submit diagnostic info”
  4. Once the info is submitted, click “Report a problem” under the “Help” menu. Tell us your OS (windows, mac), version of OS, browser, browser version, and version of your Easel driver.

This info will help the Easel development team improve the autoconnect functionality. Also, as Zach said, we will look into offering a fallback option to select your device manually (like you can with older versions of the Easel driver) if the autoconnect doesn’t work.


1 Like

I have it all going great now and will be making stuff soon. Im busy planting tomatoes right
now and installing drip irrigation system. Always something going on:)
I plan to build some cool bird house for around the garden.

Yea, they are actively working on that now.


A fix has been posted. Entering a machine’s COM port manually

1 Like