[RESOLVED] Y-Axis does not move smooth or at all [broken stepper motor]


Im just about finiched with my x-carve.
X and Z axis work great.
I can move the Y-axis by hand, but it feels like its catching on something.
When i powered the machine i got an vibration from the Y stepper motors.
When jogging, it would seem that there is not sufficient power as one moves while the other does not.
Ive checked the wiring and it is accurate. one motor is reversed.

its just shaking and does not want to move. And if it does, it just twists, while one motor is stronger then the other.

Ive tryed to increase the power, however this resulted in heavy vibrations and louder skipping steps.
The belts are firm, but they had no effect when loosened.

Please help…

Just spitballing here, my X-Carve is still a figment of my imagination…

Is all your troubleshooting so far done with the motors under power and the belts attached?
How smoothly does the gantry move by hand with no power?

You say it’s “twisting” So it looks like one side is starting to move in the direction you told it to, but the other side isn’t? That other side might be the side to focus on. Are the wheels too tight? Can you hook up a multimeter and check to see that it’s getting the same power as the first side?

EDIT: And are you 110% sure that the two sides are parallel? If they are bowed in/out then it could be binding there. It should be simple to measure the distance across at various points.

I had a similar issue, it turned out that the set screws in the drive pulley had backed out.
also check the wiring for good connections, and that the v wheels are not to tight.

il check the distances…
Did take the belts off. the results is jagged movement while turning by hand and powered.
Moving the axis itself is smooth as my baby girl skin.
However one motor just staggers and does not rotate…
This might indicate a problem with my wiring, so im going through it one more time…

the V wheels are just slipping, the setscrews are good.

I am measuring the front spacing between the makerrails at 94,85mm and at the back 94,75
You have a recomended distance? ive measured the inside…

Looks like one of the Y stepper motors are busted…

i hooked up the left stepper alone, no belts and it performed as expected…
Hooked up the right stepper alone, and the shield starts making a continius beeping sound, tried to jog and it was the same jiggering movement like its missing one wire…

So there i have it. unless someone have a miracle cure, then im stuck waiting 2 weeks for a replacement.


@christianeikefjor 2 weeks is outrageous. Are there any places in Norway that sell NEMA 23 steppers that we could buy for you?


Now, thats unexpected…
I am not really sure. A quick search revealed nothing.

Well, when im saying 2 weeks i am exageratting allittle.
One of the boxes with some bits and stuff did take 9 days from you to me.

I dont mind the wait, its just a bummer. especially since the core components was held in customs for 6 days.
It also gives me time to finish the wasteboard im making. Its too thick to fit under the v-wheels.

[edit] ive sent an email to help@inventables.

Christian Eikefjord


I got my stepper motor last week, and the machine is brought to life…
Its so satisfying having it running smoothly.

Currently designing a grid with 10cm squares to engrave on my custom wasteboard. Doing it in Easel, just so others dont need to reinvent the wheel.


So is the beeping noise the result of the stepper motor failing? Im having a problem with my y axis not moving as well. I have checked all the wires and tightened and loosened the belts but all with same result… a constant beeping noise and the light from the g shield flickering. Is it the motors?

Edit: nevermind I was able to fix it …by restarting the laptop its working fine now

I have been having the same issue since the day i bought it :frowning: . I checked and rechecked everything 100 times. I just thought maybe the rails were not rigid enough. So i have been just dealing with it. Cant put any more money into it unfortunately. So every other piece or so will jog off course :frowning: but like i said just accepted it. Nice to see the 23’s worked for you