[Resolved] Z axis depth issues

I’m struggling to get my z axis working again since I upgraded with to x carve from the shapeoko 2. I have a 24V spindle. I seem to be having some problems with depth with the machine. Whenever im in easel the bit seems to move more than it should. It either dives way to deep into the material or it doesn’t even touch it. I’m just trying to cut simple designs. I’m lost on what to try anymore. The only other problem I’m having is the y axis has some jitters only sometimes though.

I have 1000x1000 machine. No limit switches and i manual control the spindle.

Can you open up Easel, go to Machine->Advanced->Machine Inspection and post the values you see under Settings?

Ah. I’m an idiot. Haha, I never configured the thing properly in easel. I just didn’t follow instructions. Thanks for your time.

I too am having an issue with the z-axis plunging to deep. Am I to examine the same settings and adjust the z step/mm? If so, to what? I did not upgrade- bought as a 1000mm x-carve. Thanks in advance!

Are you using easel to make your cuts?


Wouldn’t hurt to take a look at your grbl settings just to see if everything looks ok.

Has it never worked or did the problem just start? I’m getting to my point don’t worry.

If the Z axis is siginificantly off, check your setup to see if your lead screw matches what Easel says it should be. M8 is different from ACME, and will give you big error every time.

1 Like

I would like to suggest a very remedial thing to check if you are experiencing inconsistent depth in the z axis. I experienced this the other day only to discover that
1 of the set screws for my z axis stepper motor belt gear had worked itself out so that under load the z axis stepper motor belt drive would slip and not have the acme screw turn. As soon as I replaced the set screw, I’m pleased to report that everything is tracking perfectly again. adding a bit of pin stripping tape to the belt drive wheels lets me visually check to make sure that they are rotating in sync.

The problem just started, but it is s new machine. It seems to be accurate on thin material (eg less than an 1/2") but inconsistent with thicker material. The rod is correct (acme). All bolts and fittings are tight. I am not very familiar with the GRBL setting. I have come to understand that the steps can be calibrated- I was thinking this could be the issue?

I should add that I am becoming familiar with GRBL but not as of yet. What setting should I be looking for?

The steps per mm settings.
$100 is X
$101 is Y
$102 is Z.

For Easel I think you go to the Machine Inspector to see the settings.

Sounds like something is causing the Z axis to bind on that upper section of ACME rod. If the rod is not perfectly straight and perpendicular to the wasteboard it may cause the delrin nut to rub against the Z mounting plate.

I would remove the Z belt and try turning the ACME rod by hand to see if that section of the rod is binding (it will become very difficult if not impossible to turn).

Did you get your problem resolved?

Same issues and so far unable to resolve through forum surfing. I have a 1000mm, Acme screw kit (silver) with limit stops and a DWP611 spindle. Everything works well except for the fact that my plunge/pass depths are off. It goes way too deep on the first pass, digging in aggressively. Primarily cutting 1/8 birch for a project and I have to “off set” and set the depth to about 1/16th to ensure it doesn’t immediately cut through on the first pass. Subsequent passes appear to be fine or just not as aggressive as the first cut.

I need to get the depth issue resolved because I cannot create tabs and have to stand over the material and monitor every pass on every piece.

Thoughts? Also, should the everything in the screenshot be set to mm? Newbie here.

I have the same issues too, got my machine done 3 days ago and when I did the test carve it did that too, I haven’t had time to play with it but I will this weekend for sure to try to fix this . If anybody have any suggestions, we need the help please, thanks in advance!

I have the NEMA 23s. Do I need to change my $102 setting in half to 94.5?

I have this same issue. The first pass is always way too deep. Seems like it plunges 2-3X deeper on the first cut. All the following passes are pretty much perfect.