[Resolved] Z-Axis not traveling far enough to Home?

Hey guys, here’s an issue I haven’t seen here before… my X-Carve is finally done and cutting nicely, but I have to run the Homing Sequence in Easel twice everytime I setup the machine! The Z-Axis doesn’t travel far enough the first time I try homing the machine to actually hit the switch… so I’ve been having to cancel the homing, restarting it, and then letting the limit switch stop the Z.
This is a little annoying, any ideas?

Thanks!
Lucian

Yep, had the same issue. A little more current to the Z-axis pot is all I needed… by a little, I mean I moved it from the 50% position to the 55% or 60% position.

1 Like

I had this issue, but not sure of the solution yet for my machine. As @sketch42 said, try bumping up your Z-current. I did this and it still stalls at the top. I never go that high, so it’s not yet a big enough issue for me to dig further. I think it may be an alignment issue with the threaded hole in the block (M8 here). I saw someone else mention that they shimmed theirs a bit.

1 Like

I had the exact same thing happen to mine, I just turned the machine off, and put a 10MM socket and extension on my cordless drill, and ran it up and down a bunch of times to make sure the delrin nut was worked in all the way to the top. Turned on the machine and tried homing and it worked great. Give this a try it may help you too. Good luck.

1 Like

Both good suggestions from @RonSwanson and @TonyNo

Okay guys new issue, probably related…
No matter what depth I tell the X-Carve to cut, it will only cut down to .05".

Help! SOS!

I mounted a dial indicator to my Z-axis and when I tell the machine to -0.1" on the Z, I measure a distance of .27", my indicator.

Looking at the settings:


Do I need to scale down the value for $102? I’m using ACME for my Z-Axis just so you guys know.

I updated line $132 just to resolve this homing travel, but I think the real issue stems from $102. Help!!!

For a quicker response, you might try contacting the Inventables help desk directly, either via email or phone:

https://www.inventables.com/about

Thanks for the help everyone, as it turns out my Stepper Driver board didn’t include the Z-Axis jumper for the MS1 MS2 thing. John from customer support told me to change the Z Steps/mm to 755.786 and it fixed this! Hope this helps people in the future.

1 Like