Inventables Community Forum

Rough & detail passes not lining up

In Easel, I’m making a rough cut with a 1 mm bit and then changing to a .3 mm bit to carve the details. It looks like it’s only shifting in the positive y direction.

I’ve been able to get the rough and idle passes synced on another piece for this project, but for THIS piece, I keep getting this result. I’ve done the idle motor lock thing, and I’m certain that the gantry is not shifting.

Also, I’m not doing this as an actual rough/detail pass in Easel. I set the detail path to a depth of 0 and cut the rough pass, then reverse this after I change the bit. I don’t see how this would make a difference, but it might.

Have you set your #4 switches inside the Xcontroller box to OFF?
(3 red switch blocks inside, switch #4 is by default set to ON, set it to OFF)

This ensure that there is no current reduction on idle steppers, maintaining maximum torque during tool changes. Set to ON the idle steppers only get 30 or 40% of the current.

You can also enable “lock motors” all the time by changing parameter $1=255 (infinite time)

Yeah, I’ve done that. The gantry isn’t shifting, at least not enough to account for the error. I actually found an earlier attempt I’d made, and the error is consistent.

What happens if you try a test carve with only one bit? (no tool change?

Well, that might point to something either being done differently or something wrong with the project? Can you share the project or just this piece?

Have you set your roughing bit and detail bits to be the EXACT diameter that each bit indicates using a set of calipers?

{:0)

Brandon Parker

It’s so easy to knock a fraction of a mm off while torquing down the collet. I lock the motors, then use quick clamps to hold the rails from moving. Yeah, it’s silly but I was sick of tiny errors ruining a 6 hour carve.

1 Like

I’ve been extremely careful. My motors are locked. In any case, the issue is repeatable. I tried it again earlier and got precisely the same result.

If you are getting exactly the same result for the same design and not seeing this issue on other designs then something is wrong in the design. While it is theoretically possible to move the gantry by the same amount each time, it is highly unlikely that you are exerting the exact same amount of force to move the gantry exactly the same distance each time.

I still run my original Uno/GRBL Shield, and with $1=255 I have never moved the gantry with the force required to remove the collet from the router. Make sure to apply counter-torque to the router during the process.

If you can share a project (even if it is just the piece that is messing up) along with what wood you are carving in and the settings being used, I might be able to do a test on my machine during the day tomorrow to see what the results are for me.

{:0)

Brandon Parker

I would also take a closer look at the easel file. Maybe there is something weird going on with the drawing. Did you draw it in Easel?

I did the $1=255 thing, and the gantry definitely isn’t moving. Because the error is precisely repeatable, I don’t think it can be due to a mechanical issue.

What I want to to is cut out the parts using a 1 mm bit, and then do the engraving with a .3 mm bit. However, when I set the detail bit, easel thinks I want to use it for the entire thing. So I copied the engraving part to a new workpiece. Everything is in exactly the same position.

The error happens whether I do it like this, or if I set the engraved lines to a depth of zero for the first pass within the same workspace.

My work zero is not machine zero. Inventables support suggested homing the machine before each pass. I think I did that on my last attempt, but I think I might have forgotten to home it before the second pass.

What I think is happening, and I won’t be able to test this until Monday, is that it’s not going back to the original zero after the first pass is completed.

I’ve output the gcode for both passes, then combined them into a single file, and everything lines up, so I don’t think it’s the gcode.

I included the easel file in another response.

The file was originally downloaded as an svg from makecnc. I redrew the engraved part in illustrator, so I don’t see how it can be the file.

Is the first cutout milling out correctly? If it is then loss of steps can be ruled out for the most part …

Re-homing between carves might resolve what your are experiencing, but find the underlying root cause would be better.

How far away from machine-zero do you have the work-zero? Is there any chance that the machine is hitting machine-zero when it returns to work-zero after the first carve?

{:0)

Brandon Parker

Yea the drawing looks fine to me. I’ll just throw out a few things just in case…

Are these the actual cut settings you’re using?

Your detail bit is set for 0.7mm depth per pass and the actual carve is only a depth of 0.6mm. It’s been a while but I feel like I have had issues while using a comparable setting. Also, how are you able to use these settings with a 0.3mm bit without it breaking?

I would try setting the depth per pass at 0.1mm and use the 0.3mm bit to carve everything in one run. It might take a little longer but it cuts out any room for error.

Yes, the first run-through is fine.

Significantly far away. What I’m going to try to determine tomorrow is whether it returns to the original work zero after the first pass.

Could there be a firmware thing going on? What is the x carve equivalent of factory reset?

The depth per pass thing might be an error, but I don’t see how it could affect the position of the bit. That is something I need to fix though.

I intentionally broke off the bit, so that I’m only carving with about a millimeter. It might still be better to use a 20 degree v bit, but it’s worked so far.

I think I would be pressing my luck trying to do that with the 3 mm plywood I’m cutting. There is a workaround that just occurred to me, though, that I’ll try tomorrow.

It’s definitely unlikely but i’ve seen easel do some weird stuff when it doesn’t like the settings. I have no clue why the carve turns out like that.

There are two of that same object in your drawing, do they both have an offset center or is it just one of them?

Not sure what you’re asking. The second workspace is just for the engraving.

Something is loose. Check your v-wheels and pulley set screws.

Nothing is loose. I’ve cut several dozen pieces to tight tolerances with no problems. Also the issue is precisely repeatable and limited to this one operation.

I mentioned that because your circles don’t look perfectly round.

With the same bits and settings? If you are putting more force on the machine, you’ll find it’s weaknesses.
Does the offset happen only when you change bits? What’s your procedure like for switching from one to the other?