Router Issue

First, I have only had my x-carve for 2 weeks. I have made about a dozen basic name signs for the grandkids. Today, I started a small fall sign and ran through roughing pass just fine. Stopped and said complete half way through detail pass. I shut the router off and now when I turn it back on the light comes on but no spin…is this bad brushes. I already order spares after reading that it is common for the brushes to go out. However, they won’t be here until tomorrow. I just want to get opinions in case it is something else. Thank you in advance.

That is not common for a new router. You should get over 100 hours out of the brushes. Since it is new you may want to get ahold of inventables and see what they say. There customer service is incredible.

What speed were you running the router on? That 100+ hours is expected out of running the router on Speed 1 all the time.


Brandon Parker

1 Like

@BrandonR_Parker It’s always on 1. I’m not quite brave enough to go beyond the basic safe zone settings. Lol

The problem is a defective speed control.
I had the same thing happen.’
Inventables replaced the router.

@JanVanderlinden Good to know, I suspected it was something other than the brushes but wasn’t sure what the issue could be. How long did it take for them to send you one? I know on basic bits and parts they are backlogged right now.

They overnight a new one to me and gave me a shipping label to ship the old one back.
Give them a call, they will set it up.

@JanVanderlinden Thanks

Thank you everyone. I received the new brushes today and just for the heck of it replaced mine (figured if it didn’t work I could put old ones back in and call inventables). It fixed the issue. I’m back up and running. Yay!! Have one back up left and already ordered more. :grin:

That’s strange.
Your router is way too new to have a brush issue.
Post a picture of the brushes that you took out.

@JanVanderlinden I will tomorrow. I already left my shop for the day.

@JanVanerlinden Old & New

I really can’t see the old one because of the angle the picture was taken
From what I can see, it still doesn’t look worn enough to cause your problem.
For a 2 week old router, that is certainly excessive wear.
I get an easy 100+ hours on a set of brushes.
But hey,if your problem is fixed, that’s all that matters right?

@JanVanderlinden Right! Lol Maybe my router was used, returned and got stuck in my setup. IDK but glad I at least tried that before calling for a replacement. Here is a picture of just the old brushes. Maybe you can see them better.

Those are pretty well worn down and look similar in length to my first set when they wore out.


Brandon Parker

Maybe the grandkids snuck in to play with your router when you weren’t home?

@MikeByrne they are a little to young. The oldest is 11 and he don’t like coming to Memaw & Papaws because we don’t have video games consoles here. Lol

1 Like

Yep,those needed replaced.
Glad you got it running.

Raymond, I had same issue twice, first time, it had to do with brushes, second time was a bad electric connection (wall plug) as simple as that