Samples of my cnc carve

what is the best value for x,y joging and z

I made the suggestion of 30IPM or 762mm/min, but it really depends on what jogging feedrate you feel comfortable with. After connecting to the com port, you can change the jogging feedrate with the Fx dropdown menu and button. The startup block $N1=F only sets the default. If your using metric units, select it in the top right of the screen.

1 Like

i use inch so please tell me only in that way , i am not use metric

OK, since your using inch units, set your jogging feedrate at 50 for the X&Y to start, and then when jogging Z, set it at 20. This is only until you feel comfortable jogging with PicSender, then you can increase the feedrates later. Set the jogging Mode to Inc. (G91).

1 Like

Can you send me a photo of the program, and how we put feed rate,and set up in steps

This is to change the feedrate.

Select the “v” next to the window and a drop down menu will appear for you to select your desired jogging feedrate, then click the Fx button to set it.

The X,Y & Z jogging buttons has drop down menus also to set the distance it will move when you click the jogging buttons. The Mode button will change to either Inc. (G91) or Abs (G90). Set it to Inc. (G91) as shown.

1 Like

This setting only use with jogging or also when I send the gcode,I mean this setting give more steps in x ,y ,z,or not.
I need to know how I can match my settings, between vcarve set and pinsender.
Yesterday when I start work with this program, it give me error in step 2.but still work after it loss steps and I stop working,

Those settings are just for jogging feedrate & step distance.

Any errors in your gcode is reported back from grbl and PicSender will display it. You will need to make sure your gcode is generated properly from vcarve with the correct post processor for grbl.

1 Like

So I set this value for jogging, and set my zero for x,y,z
Then if I need to load my file,I have to change this setting to Mach the setting in vcarve.

Yes, set your jogging values and position the spindle to your X,Y & Z starting place and Zero all the axis’s.

We don’t use vcarve, so you need to do a search on the forum for the Post Processor that is needed for grbl.

1 Like

i have this issue, before send the file it is G91, after i send the file changed to G90, also reset changed to black, after fiished the work , i can not do any things to stop spindle from program, the program was freeze,

The G91 switches to G90 because you have a G90 in the beginning of your gcode file, then at the end of the file run, it will switch back to G91 again for jogging.

Can you zip/compress your gcode file and send it to the email address your registration came from so I can look at it and test it here? Also what version of grbl are you using?

Thanks.
Jeff

1 Like

i use x-carve (inch) gcode, from inventable,how i can know which vession, arham alrahmmen.gcode (297.8 KB)

There is a problem with the Post Processor your using. There is no M05 at the end of your gcode file to turn the spindle off. There is no G90 at the beginning of your gcode file either.

When PicSender connects to the com port, it will display what version of grbl is loaded in the message window.

1 Like

grbl 0.9i
i click on M03 , it say now on in the message window, but in the program Mo3 off,
how can i add g90, g91, at the end of program to stop spindle

Thanks.

Read this to understand grbl gcode programming.

http://www.shapeoko.com/wiki/index.php/G-Code#G-code_supported_by_Grbl

2 Likes

so now what is the wrong steps i did , and how can I solve it,

Send an m05 or m5 to shut off the spindle.

The Post Processor your using is not adding the M05 or M5 to the end of your gcode file to turn off the spindle.

1 Like

when i send Mo5 before i snd the file, can you tell me the steps from the beginning to the end , what i miss, where is the mistake i did.
why it change to G90 afterI sent the file,