Saying goodbye to Easel

I’ve had my Xcarve for over three years now. Never had any serious problems with the machine or Easel that weren’t user error until recently.

Last week I waited over an hour for a simulation in Easel. Finally gave up. Tried again later and it worked as it should right away.

Today I’m halfway through a simple 2D carve and the Z axis decides it wants to go to the center of the Earth. Before you ask, the pulleys and/or the belt did not slip. I have indicator lines on these and check them regularly. Also the bit was still secure in the collet.

I may wrong, but it seems to me that ever since Inventables added V carving, the basic simple functionality has become very erratic.

In any event I will no longer be using Easel for the simple, quick stuff I do occasionally.

1 Like

What are you using instead?

Maybe electrical (EMI or bad USB cable?)

Usually use Aspire for design and send gcode with Easel. If I needing something simple and fast I’ll use Easel for the designing. Going use UGS now for sending. Never had anything unexpected happen with UGS.