Second-cut sadness, machine no longer homes

I did the out-of-the-box cut with Easel and everything was perfect. About 3/4 through the cut I paused the job so I could record how quiet the machine is. When I hit “resume” the head just wiggled back and forth about 3mm on the spot while the machine made a deep thrumming sound. It wasn’t contacting material, from what I could see at that point.

Now, attempting to do my second-ever cut, the machine won’t home. When I click Machine -> Home the device does the Z-axis homing successfully, but then makes a deep thrumming sound and either the spindle moves not at all, or a slight amount side-to-side. Here’s a video.

My current thinking is that either the X-axis stepper is shot, or maybe what I assume is a toothed gear that grips the belt and attaches to the stepper is just spinning instead of grabbing.

Any debugging suggestions? Sucks that this happened almost right out of the box. :confused:

Are you able to jog the head if you go to machine setup?

Check belt tension and make sure your zip ties didn’t come loose…

Nope, jogging the machine yields the same issue. The X axis just either wiggles back and forth or does nothing. Which zipties could come loose? I guess I should find the teardown manual.

My $0.02, make sure your vbelts aren’t too tight, then calibrate the pots, if you haven’t already.
There is a stepper calibration video from @RobertA_Rieke here.

Good Luck,
Kelly

I’m not sure about the pots. This is the machine running less than ten minutes beforehand: video. I feel like if it were the pots I would have seen symptoms on the first cut. I took another video where I caught it moving before failing to home: video. That’s just using Easel’s Machine -> Home. I thought it was only supposed to look for the left-side limit switch, but maybe that’s incorrect.

I tried looking in the Carvey manual for adjusting the X-axis belts, but that section is blank (scroll all the way to the bottom), so I’m going to write support to see if they can lend a hand.

So I put my phone and a flashlight on the cutting platform to see if I could see what was going on when it tried to home. It looks like this! As you can see, the carriage moves to the left in the video, which is to the right of the stage. However, the direction that the carriage travels varies when I try to home. Sometimes it doesn’t move at all. More often than not it moves right then left once it gets near the right side of the stage.

The video ends too soon (not sure why, Android just decided to stop) but you can see that the carriage stops moving even though the thrumming sound continues.

A few questions:

  1. When homing, does Carvey ever move right? From my first video, it appears to only seek the left limit switch. I don’t even know if there is a right limit switch…
  2. Can bad pot settings cause the steppers to go the wrong direction? I haven’t touched the pots (because I didn’t want to start disassembling the machine yet) so it seems strange that it would go from cutting fine to not even moving in the space of 10 minutes because of them.
  3. What kind of stepper driver does Carvey use? If one channel failed in a stepper controller I feel like it could cause this kind of behavior, but I’m not 100% sure of that.

Usually the strange direction travel is caused by a loose wire to the motors on the x-carve, not sure how that works with the carvey,

1 Like

Interesting, I hadn’t even thought that it might just be one of the channels not connecting (or partially/occasionally connecting) which would explain why the carriage sometimes moves right then left or not at all.

The manual doesn’t cover how to get access to the stepper connectors. Customer Success says they’re passing my issue on to the engineers, so maybe I’ll wait to see if they’ve got anything for me before I tear the back plate off.

1 Like

It was a loose wire to the X-axis stepper. I pulled the back plate and reseated all of the stepper connectors and it cuts like a charm now.

1 Like

Have you talked to Inventables Support?
I really like the homing feature, I did break several switches early on, so I bought a 10 pack from amazon.
I’ve recently had to put a block of wood under the X and Y “stops” for the limit switches, as I found that the rollers were sometimes getting stuck under the stop bolts, which caused homing issues.

-Kelly

Here’s a for instance that I ran into in the last week.
I’m doing a project where I’m cutting 4 sides of a block of wood, with tool changes, so lots of opportunities to screw it up.
I started a cut with a badly placed clamp, the machine ran into it and lost a ton of steps, I was in the last stage, where the zero point on the block of wood no longer existed, so re-zeroing would have been difficult to do well.
I re-homed the machine, started the carve again, said use last home position, and it “just worked”.
I could not have done that without limit switches / homing ability, although I could have come up with some other solution, this was simple.

-Kelly

1 Like

I had a similar problem with the touch plate not working on my x-carve, I talked to support, they sent me a new arduino, and it all works now.

If the switches and wiring test out, and are connected in the right place, then you most likely either need to reflash the arduino or replace the arduino.
YMMV.

-Kelly

1 Like