Setting limit switches x y z

setting limit switches x y z. why does the z axis travel down when trying to set the limit switch that is in the up position

Do the Z axis travel in the correct direction when you jog it?
What is your GRBL $23 parameter currently set to?

unknown where do i check those

First of all you need to decide wether to use them as limit switches or homing switches, I assume the latter :slight_smile:

GRBL parameter $23 govern which way the axes will seek their respective homing switch.
Z axis is the first to seek, then followed by X and Y.

Since Z moves down we need to establish that the axis work as intended (jog up = up motion) in order to rule out issues with the machine setup.

To see what GRBL parameters are set to, open Easel, choose Machine Inspector and in the Console window type $$ and press Enter
In the window below a list of all $-parameters will be displayed. Post them here :slight_smile: