Setting up a new machine - a few questions, a few problems

hi guys

any help for a x-controller beginner would be much appreciated. I have had a look around prior to asking here so not to clog the forum but couldn’t find anything for the remaining issues or using the wrong search words.

my setup is
Machine - Oozenest OX Cnc even though different to the x-carve it still operates with the same prinicples
with the
Inventables - X-Controller

  • have wired up everything and debugged an issue a few weeks back in relation to motors and driving the correct way
  • machine homes to X, Y and Z microswitch homing
  • have adjusted the machine size and still tweaking the calibration - some odd things going on there
  • has GT3 belts and GT3 20T Pulleys on the X & Y and 8mm ACME thread rod for the Z axis

my issues:
?1 - when setting up machine settings there is a tab for downloading GRBL v1.1f - but crashes and fails everytime - is there a problem at there end or mine?

?2 - I am probably doing something wrong but I want to know how to type in my G28 home and G30 home - can I do this within Easel or is that only available in a 3rd party driving software

?3 - calibration of the X & Y - since my machine is a little different to a X-Carve the motors are still 1.8degree Nema 23s with 20 tooth pulleys and GT3 belt and in theory the $100 and $101 should be the same but my Y calibration just seems to vary 0.5mm each time ?

?4 - when jumping between the machine settings and Carve to physically drive the machine 10mm increments to check my calibration sometimes when I come in the jog screen and push a X or Y axis direction button the machine randomly decides to drive in a 100 / 100 X / Y direction sometimes towards the centre of the machine and sometimes crashing in the homing switches - is there something in easel that is causing weird issues?

any help / advice would be much appreciated and again sorry if this is mentioned else where.


I use an Arduino UNO and home made controller, in most practical terms equal:

Dont know :wink:

Jog to intended G28 or G30 position
In Easel open Machine Inspector (CTRL+SHIFT+D or CMD+SHIFT+D on Mac)
Type the command G28.1 to set that point as G28 parking space and you are done

Jog each axis as long in one direction as possible and confirm with a ruler.
Say you command 500mm and it move 467mm
467 divided with current step/mm value multiplied with intended travel (500) give you the recalculated GRBL setting for that axis.
0.5mm however might be from backlash and/or slight calibration offset.
If you move in 100mm increments are each increment measured to 100mm also? Or are each 99,5mm? Or only the first is 99,5 after change in direction?

4 - Sounds odd…

thanks @HaldorLonningdal for your thoughts

1 - anyone else having issues with downloading the latest update?
2 - I will try this a little later on @HaldorLonningdal, I am on a Mac but where do I type that in within Easel.
3 - I will have to try larger movements and I know the selection is 0.1,1 and 10mm - never thought if I could type in a custom amount - if I am understanding correctly…
4 - yes it is odd and the machine can be off all the sensors and when you hit a direction button it can drive the determined amount or just decides to go in random directions and crash and buggering up switches.

any other feedback would be much appreciated

did a little testing today
1 - downloading still fails and crashed my computer (Mac) in the attempt - anyone else having issues?
2 - I couldn’t work out where to type the command G28.1 - can someone provide a screen shot of where I can do this - also maybe check my settings as maybe I haven’t activated this ???
3 - did some calibration of a longer distance and getting it close, thanks - SOLVED
4 - hasn’t done it today

here are my settings

$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000011)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=115 (status report mask:01110011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=3.000 (homing pull-off, mm)
$30=1. (rpm max)
$31=0. (rpm min)
$100=26.667 (x, step/mm)
$101=26.936 (y, step/mm)
$102=50.150 (z, step/mm)
$110=8000.000 (x max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=500.000 (x accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=790.000 (x max travel, mm)
$131=1250.000 (y max travel, mm)
$132=51.000 (z max travel, mm)

2 - You copied the GRBL settings by first calling the list using the $$-command?
This is the same place you type the G28.1 command.

Machine Inspector Console:

1 Like

When I open machine inspector the GRBL setting are displayed with sending any command.
g28.1 command goes in the field marked Console.

1 Like

thanks guys I will have to check tonight when I have a moment, life’s busy

I checked with ooznest (ox cnc) and they said my Z axis step rate for $102 should be around 200 and not 50.150.

Does anyone know what the x-controller board is set at?

when setting up the machine I did select the 8mm acme lead screw which is the design as currently at the 50.150 rate it is very noisy.

thanks for the help everyone

got a chance to play with some of the settings and update is:

1 - downloaded GRBL 1.1f still fails
2 - have worked out how to set and use G28 and G30 - consider Solved.
3 - Solved
4. - this hasn’t occured anymore - consider “Solved”

A few new questions related to the setup:

?5. on the Machine Inspector after I type in $H for home how do I get the Machine position and work position to deisplay 0,0,0 as has really high numbers?

?6. checked with oozenest in regards to the $102 and they reckon it should be 200, could a unique setting be calibrated when setting the Z drive as I selected a now old Acme 8mm rod, should I select the x-carve one and tweak the calibration

?7. how do I change 30.1 to further than the existing as it seems like I can’t drive the further further than that setting and if I try the machine goes into a error and then tells me to reset the machine.

?8. is the only way to reset the machine by turning the X-controller off and back on 10seconds later?

?9. how do I tell the machine in Machine Inspector to drive a set distance say of x=500, y=1200 (machine’s driving limits is 800 x 1270mm) ?

thanks for any help in advance.

Is the Z moving the right distance? If so, then you’re using a different microstep amount then what they use. If they use 8X, the Xcontroller default is 2X for Z, which explains the 4X difference between your setting and their setting.


5 - Machine Homing position i Machine Zero. The work space reachable by the CNC is all in the negative space.
GRBLvalue for $27 = pull-off distance from the switches, default = 1mm so after a homing cycle the machine will report X/Y/Z as "-1.000)

Work position / Easel Home position (start/stop point for your carve) can be anywhere within the reachable workspace.

6 - Doesnt matter what you start with, its the function between microstepping / step per mm that matter.
Always tweak step/mm on a new machine, variations may occur.

7 - G30.1 set current machine position as parking space G30, not sure what you mean.

8 - Dont have one so cant tell. Std Ardunio have a generic reset button.

9 - In Easel you do that by clicking the green Carve button, upper right. In the jog panel you can type in intended distance. One click = one distance.

With Homing enables you are allowed to activate soft limits ($20=1)
You can then define the max allowed travel on all axes, if trying to push past them an alarm state will occur.

1 Like

Always set microstepping to the manufacturers recommendations and THEN tweak steps/mm.

1 Like

Agreed, sometimes though introducing the whole “microstepping issue” may become a confusing element in the road towards the primary goal, to get the machine operational. But RTM :slight_smile:

Microstepping primary function is to make the machine run smooth, not accuracy gain. So if full step is rough, try 1/2 step, if still rough try 1/4 etc.

i have the same problem with downloading grbl 1.1 and i am on a mac too.

was thinking something like that but will re-do the machine setup just to see if there is a bug in the x-controller setup - something different in the z screw setup

I had this originally and when I told it to drive 1mm it drops heaps more and on the current setting it just sounds very noisy I think due to the step rate

I will do a few different tests and reply back today as early morning here and got some time today

ok, could be a Mac thing at the moment

@JadySwinkels @AA1

Is this the method you are using to upload to the Mac?

To upload the hex file:

•Windows: We use the XLoader program
•Mac: Paul Kaplan’s Uploader

no was using the link within EASEL

me too. it says update available click to download. and the it doesnt seem to download.

is that what youre getting?