Shapeoko goes haywire halfway through job

I did a quick search and couldn’t find this as a topic anywhere.
I have been carving some simple shapes (just numbers 1 - 8 about 60mm high) using Easel to generate the G-Code. I have successfully carved a couple of these but I keep ruining my nice oak boards because after a varying amount into some jobs (it’s a 22mm deep cut) the cutter goes out of control and carves randomly across the work area and I have to abort. It’s not the G-Code because I have re-tried a job that I previously aborted and was successful.
Any ideas anyone?
Thanks in advance.

Sounds like a wiring issue.

Thanks Chris.
That was going to be my next investigation but I too fed up with it to do it today!! :frowning:

The other possibility is lost steps.

If you have homing switches, break the job down into small, discrete tasks, each of which can be completed, and the machine re-homed in-between.

Given that it happens a while into the cut, your drivers may be overheating and shutting down to preserve their health.

Skipped steps from cutting too deep or fast usually result in small offsets, not generally seen as going haywire.

Does it happen at similar locations each time?

My gshield arduino combo used to overheat a lot. The way the fan was positioned on the driver put air on the x and z drivers, but created a pocket of no air on the y driver. I added heatsinks to the drivers and strategically drilled holes in the housing and used tape to increase and shape the airflow over the drivers. I could offer some suggestions on this if you feel overheating might be the problem

1 Like

Thanks Will and Jeremy for your inputs. I did find a loose wire and thought “hah, found the problem” but even after fixing the wire it messed up on the next but one job (it did the first one perfectly). So - maybe it is an overheating issue. I’m trying to think of a common denominator for the fault and maybe it’s that it happens after a reasonably long period of work and is therefore down to heat build up. I’ll give that a go and see what happens.
Thanks again.

Well - I tried again this morning and had to abort about a third of the way into the job. There was no evidence that the electronics were getting hot (or even just warm). The carving was going well and then it simply decided to cut across the work at a random angle. It wasn’t along an axis, just random (see pic)

I think I’ll have to take everything to bits and rebuild to make sure it’s not a wiring issue - even though I have managed to complete a similar job successfully yesterday.

How does the job preview?

The one software cause I’m aware of for this sort of thing is too-long lines w/ too many numerals after the decimal — Grbl has a 50 or 70 character limit depending on version. Usually those are perfectly repeatable.

Looks to me as if belt tension is insufficient (or you don’t have your pulley set screws on flats) and the belt is slipping — slotting increases the likelihood of this — add geometry and cut as a pocket, not a profile path after checking/adjusting the belts.

That deviation is almost identical to what I had when my Y axis would freak out. The x would still function so it would still move sideways but the Y axis would stop functioning properly.

If it is overheating you can combat the issue by either improving cooling or decreasing current. If you are dialed all the way to full power, you’re making that driver work and it WILL get hot.

What is your DOC and speed for this cut?

Will is correct that loose pulley and or belt tension can also cause similar outcomes. It is less likely on the y axis to have both motors/belts slip to the point that Y axis travel nearly completely ceases. Generally one side will have a problem and cause a twisting of the gantry but it will still continue to travel in the Y direction.

To answer your questions…doc is 1mm/pass and the last problem was experienced at about 9mm deep. Speed is 1500mm/min. I didn’t think that was too onerous but maybe I should slow it down a bit. I’ve nothing to lose as it’s not working with the settings as they stand!
I think belt tension might be a good route to follow. I’ve not checked it for a while and the machine has been out in the cold garage all its life.
I’ll check and report back.:grin:

…and to answer Will’s question - the preview is absolutely fine. Shows no divergence from the expected paths. The command lengths are quite short but I’ll count the characters to make sure.

You shouldnt have any issues whatsoever with that DOC and feed rate. Something else is definitely going on. Check a few things and get back to us if you need some more guidance.

@PaulSilvey were you able to find a solution to this issue?

It wasn’t software as I managed to complete a number of successful cuts after I gave the SO a good clean up. However, it’s just messed up again so I’m looking for something else. I noticed one of the wheels was a bit tight to its rail so I will have another test after sorting that out.