Shapeoko2 Arduino/gShield Not responding

Hello all!
Would love some help if you could.
Last week I started losing a few steps on cuts so I let it settle until we were back from vacation. Came back and I have been unable to get Easel to connect to the controller…
These are the things I’ve done:

  • Pulled out the arduino board and tried to connect via IDE all good there.
  • Figured I’d try to reflash the Board using Zach Kaplan’s loader. I attempted to load it with: inventables_grbl_09j_2015_07_17.hex using these instructions.
  • During one of the flashes I noticed it was losing connection. So I ordered a new Arduino Uno board. I ordered this one… Arduino Uno R3 Microcontroller A000066
  • I flashed it with the same GRBL listed above. Still no go.

I realize I may be using the wrong combinations of things but I’m at a bit of a loss.
Any further information that you may need to help me get this running again, please ask! I’d really appreciate any help here!


Well… some updates.

  • I was able to get .8c, .9i, and .9g loaded on the Arduino.
  • I was able to connect to the new arduino with UGS. (it would constantly come up with an alarm because it doesn’t know where the head is. I don’t have limit switches).
  • Easel will identify that a machine is connected. The carve button is green. However, when I go into “machine” to update the settings for my machine (Shapeoko 2, arduino+Gshield, 500x500, other cutting head) it gets in a constant loop when it tries to update the settings.

I’m giving up for tonight. Any help anyone can offer, I’d love help.

I made sure that the arduino and the gshield are fully connected as well.
The power light on the gshield is on and when manually moving the gantry, the lights illuminate.

Thanks Phil! My baud rate is set to 115200 and port settings are good to go. I’m able to connect to the board in UGS.
I need to kill the bits for homing and soft limits. I’m struggling a bit on that.

Can someone confirm what the best grbl release is best for my Shapeoko2? I’d like to make sure that I have that appropriately squared away.

Also, I ordered a new gShield last night. After further testing, I was able to get Easel to identify the arduino but I wansn’t able to jog the spindle at all. I’m thinking that maybe the gShield is shot. It’s almost like a power surge may have popped them both. The power light on the gShield comes on, I get leds to light from manual manipulation of the gantry, but it doesn’t seem to be getting orders from the Ardiuno on when to move. I double checked that my polarity from the PSU was correct as well. Frustrating.

Thanks Phil. I’ll give it a shot.

1 Like