Signing into easel and what gives?

I was able to sign into easel once. Since then I try to sign in and I keep getting redirected to the sign into the inventables page. I use chrome and have tried using IE but nothing seems to work still.

Any thoughts

I’m not sure what you’re asking. Easel requires a sign-in. I’m assuming that’s for tracking and storage purposes. I just logged into Easel with no problem. Since I’m logged into this forum, Easel went to the page that says to log in via Inventables. I clicked on the button and went to Easel.

Yes that what I also do but it just keeps redirecting me to the login page. Not sure why its happening I’ve contacted support and seems to be a problem on my end, but haven’t been able to figure it out.

Hi there,

It might be worth trashing your cache, and restarting your browser…just a thought.

Hope you manage to get it working.

All the best


Yup tried that just now and still the same thing.

Hi Brandon,

Try this:-

Adjust cookie and site data permissions

Click the Chrome menu Chrome menu on the browser toolbar.
Select Settings.
Click Show advanced settings.
In the “Privacy” section, click the Content settings button.
In the “Cookies” section, you might need to change the following cookies settings:

Make sure “Allow local data to be set” is selected to allow both first-party and third-party cookies.

It might also be worth checking which version of Chrome you are using…an update might also solve the issue.

All the best


Hi Brandon,

In IE8…

First of all, go into your Internet Options - Security.

Then you need to put ‘Inventables’ as a trusted site (for some reason, the protection mode sometimes blocks new or even trusted accounts).
To do this click onto the icon that should look like a tick (Says “Trusted sites” under it) and click the sites button to add a website (pretty self-explanitary). Dont forget to untick “Require server verification…” or it wont accept any site without https://.

Exit out of that window and make sure “Enable Protected Mode” is unticked while you have Trusted sites selected.

All the best


Welp still nothing. Wonder if it has anything to do with bitdefender software?

Hi Brandon,

Bitdefender could be the issue…it’s an extremely effective bit of software, but your settings might need adjusting.

What to do when Bitdefender 2015 blocks a safe website or online application

Bitdefender offers a secure web browsing experience by filtering all web traffic and blocking any malicious content. However, it is possible that Bitdefender considers a safe website or online application as unsafe, which will cause Bitdefender HTTP traffic scanning to block them incorrectly.

Should the same page or application be blocked repeatedly, they can be added to a whitelist so that they will not be scanned by the Bitdefender engines, thus ensuring a smooth web browsing experience.

To add a website to the Whitelist, follow these steps:
Open the Bitdefender window.
Access the Protection panel.
Click the Web Protection module.
In the Settings tab, click the Whitelist link. A new window will appear.
Provide the address of the blocked website or online application in the corresponding field and click Add.
Click Save to save the changes and close the window.
Only websites and applications that you fully trust should be added to this list. These will be excluded from scanning by the following engines: malware, phishing and fraud.

All the best


If your notifications are turned off…it could be that Bitdefender is protecting you from a false positive…but not able to tell you.

Make sure you don’t have an ad-blocker enabled. This can sometimes cause issues.

Checked that to. Crazy thing is that I went out to the shop laptop and I couldn’t log in on that one also.